summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2-native_2.4.34.bb')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2-native_2.4.34.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.34.bb b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.34.bb
deleted file mode 100644
index 4cc384546..000000000
--- a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.34.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1DESCRIPTION = "The Apache HTTP Server is a powerful, efficient, and \
2extensible web server."
3SUMMARY = "Apache HTTP Server"
4HOMEPAGE = "http://httpd.apache.org/"
5DEPENDS = "expat-native pcre-native apr-native apr-util-native"
6SECTION = "net"
7LICENSE = "Apache-2.0"
8
9inherit autotools pkgconfig native
10
11SRC_URI = "${APACHE_MIRROR}/httpd/httpd-${PV}.tar.bz2 \
12 file://0001-configure-use-pkg-config-for-PCRE-detection.patch \
13 file://CVE-2018-11763.patch \
14 "
15
16S = "${WORKDIR}/httpd-${PV}"
17
18LIC_FILES_CHKSUM = "file://LICENSE;md5=d52d0fd0bc788f068e647116c01ddfcd"
19SRC_URI[md5sum] = "818adca52f3be187fe45d6822755be95"
20SRC_URI[sha256sum] = "fa53c95631febb08a9de41fd2864cfff815cf62d9306723ab0d4b8d7aa1638f0"
21
22EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
23 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \
24 --prefix=${prefix} --datadir=${datadir}/apache2 \
25 "
26
27do_install () {
28 install -d ${D}${bindir} ${D}${libdir}
29 cp server/gen_test_char ${D}${bindir}
30 install -m 755 support/apxs ${D}${bindir}/
31 install -m 755 httpd ${D}${bindir}/
32 install -d ${D}${datadir}/apache2/build
33 cp ${S}/build/*.mk ${D}${datadir}/apache2/build
34 cp build/*.mk ${D}${datadir}/apache2/build
35 cp ${S}/build/instdso.sh ${D}${datadir}/apache2/build
36
37 install -d ${D}${includedir}/apache2
38 cp ${S}/include/* ${D}${includedir}/apache2
39 cp include/* ${D}${includedir}/apache2
40 cp ${S}/os/unix/os.h ${D}${includedir}/apache2
41 cp ${S}/os/unix/unixd.h ${D}${includedir}/apache2
42
43 cp support/envvars-std ${D}${bindir}/envvars
44 chmod 755 ${D}${bindir}/envvars
45}
46