diff options
Diffstat (limited to 'meta-systemd')
-rw-r--r-- | meta-systemd/classes/systemd.bbclass | 16 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bbappend (renamed from meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bbappend) | 0 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend | 14 | ||||
-rw-r--r-- | meta-systemd/recipes-core/systemd/systemd-compat-units.bb | 2 | ||||
-rw-r--r-- | meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service | 2 |
5 files changed, 12 insertions, 22 deletions
diff --git a/meta-systemd/classes/systemd.bbclass b/meta-systemd/classes/systemd.bbclass index 4036f91ca..96d7f8f55 100644 --- a/meta-systemd/classes/systemd.bbclass +++ b/meta-systemd/classes/systemd.bbclass | |||
@@ -2,6 +2,8 @@ DEPENDS_append = " systemd-systemctl-native" | |||
2 | 2 | ||
3 | SYSTEMD_AUTO_ENABLE ??= "enable" | 3 | SYSTEMD_AUTO_ENABLE ??= "enable" |
4 | 4 | ||
5 | SYSTEMD_AUTO_RRECOMMENDS ??= "enable" | ||
6 | |||
5 | systemd_postinst() { | 7 | systemd_postinst() { |
6 | OPTS="" | 8 | OPTS="" |
7 | 9 | ||
@@ -208,12 +210,14 @@ python populate_packages_prepend () { | |||
208 | if len(rdepends_arr) == 0 and pkg_systemd != '${PN}' and not pkg_systemd_base in rdepends: | 210 | if len(rdepends_arr) == 0 and pkg_systemd != '${PN}' and not pkg_systemd_base in rdepends: |
209 | rdepends = '%s %s' % (rdepends, pkg_systemd_base) | 211 | rdepends = '%s %s' % (rdepends, pkg_systemd_base) |
210 | d.setVar('RDEPENDS_' + pkg_systemd, rdepends) | 212 | d.setVar('RDEPENDS_' + pkg_systemd, rdepends) |
211 | # RRECOMMENDS_${pkg_systemd_base} += pkg_systemd systemd | 213 | auto_rrecommends = d.getVar('SYSTEMD_AUTO_RRECOMMENDS', 1) or 'enable' |
212 | rrecommends = d.getVar('RRECOMMENDS_' + pkg_systemd_base, 1) or "" | 214 | if auto_rrecommends == 'enable': |
213 | # not rrecommending myself AND avoid double entries | 215 | # RRECOMMENDS_${pkg_systemd_base} += pkg_systemd systemd |
214 | if pkg_systemd != pkg_systemd_base and not pkg_systemd in rrecommends.split(): | 216 | rrecommends = d.getVar('RRECOMMENDS_' + pkg_systemd_base, 1) or "" |
215 | rrecommends = '%s %s' % (rrecommends, pkg_systemd) | 217 | # not rrecommending myself AND avoid double entries |
216 | d.setVar('RRECOMMENDS_' + pkg_systemd_base, rrecommends) | 218 | if pkg_systemd != pkg_systemd_base and not pkg_systemd in rrecommends.split(): |
219 | rrecommends = '%s %s' % (rrecommends, pkg_systemd) | ||
220 | d.setVar('RRECOMMENDS_' + pkg_systemd_base, rrecommends) | ||
217 | 221 | ||
218 | # run all modifications once when creating package | 222 | # run all modifications once when creating package |
219 | if os.path.exists('${D}'): | 223 | if os.path.exists('${D}'): |
diff --git a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bbappend b/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bbappend index 950476157..950476157 100644 --- a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bbappend +++ b/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bbappend | |||
diff --git a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend b/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend deleted file mode 100644 index 1026e220f..000000000 --- a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | PRINC := "${@int(PRINC) + 1}" | ||
2 | |||
3 | inherit systemd | ||
4 | |||
5 | SYSTEMD_PACKAGES = "${PN}-systemd" | ||
6 | SYSTEMD_SERVICE = "${PN}.socket" | ||
7 | SYSTEMD_OESCONS = "true" | ||
8 | |||
9 | do_install_append() { | ||
10 | #support for systemd | ||
11 | install -d ${D}${systemd_unitdir}/system/ | ||
12 | install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service | ||
13 | install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket | ||
14 | } | ||
diff --git a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb index aefd6a758..6b6b4dda9 100644 --- a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb +++ b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "Units to make systemd work better with existing sysvinit scripts" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" |
5 | 5 | ||
6 | PR = "r17" | 6 | PR = "r18" |
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
diff --git a/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service b/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service index 879a25157..da6fe76a3 100644 --- a/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service +++ b/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service | |||
@@ -2,7 +2,7 @@ | |||
2 | Description=Run pending postinsts | 2 | Description=Run pending postinsts |
3 | DefaultDependencies=no | 3 | DefaultDependencies=no |
4 | ConditionPathExists=|/etc/rcS.d/S98run-postinsts | 4 | ConditionPathExists=|/etc/rcS.d/S98run-postinsts |
5 | After=remount-rootfs.service | 5 | After=remount-rootfs.service tmp.mount |
6 | Before=sysinit.target | 6 | Before=sysinit.target |
7 | 7 | ||
8 | [Service] | 8 | [Service] |