summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind/rpcbind.service13
-rw-r--r--meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend14
2 files changed, 0 insertions, 27 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind/rpcbind.service b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind/rpcbind.service
deleted file mode 100644
index a028acebe..000000000
--- a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind/rpcbind.service
+++ /dev/null
@@ -1,13 +0,0 @@
1[Unit]
2Description=RPC Bind
3After=network.target
4Wants=rpcbind.target
5Before=rpcbind.target
6
7[Service]
8Type=forking
9ExecStart=/usr/sbin/rpcbind
10Restart=always
11
12[Install]
13WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
index 9f83f65d0..5cb6bf434 100644
--- a/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
@@ -1,19 +1,5 @@
1inherit systemd
2
3PRINC := "${@int(PRINC) + 2}" 1PRINC := "${@int(PRINC) + 2}"
4 2
5# look for files in the layer first
6FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
7
8SRC_URI += "file://rpcbind.service"
9
10RPROVIDES_${PN} += "${PN}-systemd" 3RPROVIDES_${PN} += "${PN}-systemd"
11RREPLACES_${PN} += "${PN}-systemd" 4RREPLACES_${PN} += "${PN}-systemd"
12RCONFLICTS_${PN} += "${PN}-systemd" 5RCONFLICTS_${PN} += "${PN}-systemd"
13SYSTEMD_SERVICE_${PN} = "rpcbind.service"
14
15do_install_append() {
16 install -d ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
18}
19