summaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-compat-units.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
index 2973208b1..aefd6a758 100644
--- a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Units to make systemd work better with existing sysvinit scripts"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5 5
6PR = "r16" 6PR = "r17"
7 7
8inherit allarch 8inherit allarch
9 9
@@ -38,11 +38,17 @@ SYSTEMD_DISABLED_SYSV_SERVICES = " \
38pkg_postinst_${PN} () { 38pkg_postinst_${PN} () {
39cd $D${sysconfdir}/init.d 39cd $D${sysconfdir}/init.d
40 40
41echo -n "Disabling the following sysv scripts: " 41echo "Disabling the following sysv scripts: "
42
43OPTS=""
44
45if [ -n "$D" ]; then
46 OPTS="--root=$D"
47fi
42 48
43for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do 49for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
44 if [ \( -e $i -o $i.sh \) -a ! -e $D${base_libdir}/systemd/system/$i.service ] ; then 50 if [ \( -e $i -o $i.sh \) -a ! -e $D${sysconfdir}/systemd/system/$i.service ] ; then
45 echo -n "$i " ; ln -s /dev/null $D${base_libdir}/systemd/system/$i.service 51 echo -n "$i: " ; systemctl ${OPTS} mask $i.service
46 fi 52 fi
47done ; echo 53done ; echo
48} 54}