summaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd/systemd-serialgetty.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-serialgetty.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd-serialgetty.bb b/meta-systemd/recipes-core/systemd/systemd-serialgetty.bb
deleted file mode 100644
index c3106722f..000000000
--- a/meta-systemd/recipes-core/systemd/systemd-serialgetty.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1DESCRIPTION = "Systemd serial config"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=751419260aa954499f7abaabaa882bbe"
4
5PR = "r3"
6
7SERIAL_CONSOLE ?= "115200 ttyS0"
8
9SRC_URI = "file://LICENSE \
10 file://serial-getty@.service"
11
12def get_serial_console_value(d, index):
13 c = d.getVar('SERIAL_CONSOLE', True)
14
15 if len(c):
16 return c.split()[index]
17
18 return ""
19
20def get_baudrate(d):
21 return get_serial_console_value(d, 0)
22
23def get_console(d):
24 return get_serial_console_value(d, 1)
25
26do_install() {
27 if [ ! ${@get_baudrate(d)} = "" ]; then
28 sed -i -e s/\@BAUDRATE\@/${@get_baudrate(d)}/g ${WORKDIR}/serial-getty@.service
29 install -d ${D}${systemd_unitdir}/system/
30 install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/
31 install ${WORKDIR}/serial-getty@.service ${D}${systemd_unitdir}/system/
32
33 # enable the service
34 ln -sf ${systemd_unitdir}/system/serial-getty@.service \
35 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(d)}.service
36 fi
37}
38
39PACKAGES = "${PN} ${PN}-dbg ${PN}-dev ${PN}-doc"
40
41RRECOMMENDS_${PN} = ""
42RDEPENDS_${PN} = "systemd"
43
44# This is a machine specific file
45FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}"
46PACKAGE_ARCH = "${MACHINE_ARCH}"