summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend
new file mode 100644
index 000000000..3a22fe3bd
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/at/at_3.1.14.bbappend
@@ -0,0 +1,16 @@
1inherit systemd
2
3# look for files in the layer first
4FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
5
6SRC_URI += "file://atd.service"
7
8RPROVIDES_${PN} += "${PN}-systemd"
9RREPLACES_${PN} += "${PN}-systemd"
10RCONFLICTS_${PN} += "${PN}-systemd"
11SYSTEMD_SERVICE_${PN} = "atd.service"
12do_install_append() {
13 install -d ${D}${systemd_unitdir}/system
14 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
15}
16