summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index c0276a391..281c44043 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -4,8 +4,14 @@ PRINC := "${@int(PRINC) + 1}"
4 4
5inherit systemd 5inherit systemd
6 6
7SYSTEMD_PACKAGES = "${PN}-systemd" 7SYSTEMD_PACKAGES = "${PN}"
8SYSTEMD_SERVICE = "portmap.service" 8RPROVIDES_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "portmap.service"
9SYSTEMD_AUTO_ENABLE = "disable" 10SYSTEMD_AUTO_ENABLE = "disable"
10 11
11SRC_URI_append = " file://portmap.service" 12SRC_URI_append = " file://portmap.service"
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
16}
17