diff options
Diffstat (limited to 'meta-ruby')
-rw-r--r-- | meta-ruby/recipes-devtools/ruby/ruby/ruby-mkmf.rb-fix-race-conditions-at-install-ext.patch | 31 | ||||
-rw-r--r-- | meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb | 1 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/ruby-mkmf.rb-fix-race-conditions-at-install-ext.patch b/meta-ruby/recipes-devtools/ruby/ruby/ruby-mkmf.rb-fix-race-conditions-at-install-ext.patch new file mode 100644 index 000000000..5ac5d54a3 --- /dev/null +++ b/meta-ruby/recipes-devtools/ruby/ruby/ruby-mkmf.rb-fix-race-conditions-at-install-ext.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | Subject: [PATCH] mkmf.rb: fix race conditions at install-ext | ||
2 | |||
3 | Upstream-Status: backport | ||
4 | |||
5 | * lib/mkmf.rb (create_makefile): fix race conditions at install-ext. | ||
6 | target files need to depend on destination directory timestamp | ||
7 | files, not phony trgets. | ||
8 | |||
9 | git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36863 b2dd03c8-39d4-4d8f-98ff-823fe69b080e | ||
10 | |||
11 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | ||
12 | --- | ||
13 | lib/mkmf.rb | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/lib/mkmf.rb b/lib/mkmf.rb | ||
17 | index 556684c..a277354 100644 | ||
18 | --- a/lib/mkmf.rb | ||
19 | +++ b/lib/mkmf.rb | ||
20 | @@ -2055,7 +2055,7 @@ static: $(STATIC_LIB)#{$extout ? " install-rb" : ""} | ||
21 | for f in files | ||
22 | dest = "#{dir}/#{File.basename(f)}" | ||
23 | mfile.print("install-rb#{sfx}: #{dest}\n") | ||
24 | - mfile.print("#{dest}: #{f}\n") | ||
25 | + mfile.print("#{dest}: #{f} #{timestamp_file(dir)}\n") | ||
26 | mfile.print("\t$(Q) $(#{$extout ? 'COPY' : 'INSTALL_DATA'}) #{f} $(@D#{sep})\n") | ||
27 | if defined?($installed_list) and !$extout | ||
28 | mfile.print("\t@echo #{dest}>>$(INSTALLED_LIST)\n") | ||
29 | -- | ||
30 | 2.0.0 | ||
31 | |||
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb index 24bacdc4c..2d5938f87 100644 --- a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb +++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb | |||
@@ -11,6 +11,7 @@ SRC_URI += "\ | |||
11 | file://ruby-1.9.3-mkmf-verbose.patch \ | 11 | file://ruby-1.9.3-mkmf-verbose.patch \ |
12 | file://ruby-1.9.3-install-cross.patch \ | 12 | file://ruby-1.9.3-install-cross.patch \ |
13 | file://remove-the-dependency-on-dir.patch \ | 13 | file://remove-the-dependency-on-dir.patch \ |
14 | file://ruby-mkmf.rb-fix-race-conditions-at-install-ext.patch \ | ||
14 | " | 15 | " |
15 | SRC_URI[md5sum] = "7531f9b1b35b16f3eb3d7bea786babfd" | 16 | SRC_URI[md5sum] = "7531f9b1b35b16f3eb3d7bea786babfd" |
16 | SRC_URI[sha256sum] = "9ba118e4aba04c430bc4d5efb09b31a0277e101c9fd2ef3b80b9c684d7ae57a1" | 17 | SRC_URI[sha256sum] = "9ba118e4aba04c430bc4d5efb09b31a0277e101c9fd2ef3b80b9c684d7ae57a1" |