summaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb
new file mode 100644
index 000000000..834cb7187
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby_1.9.3-p547.bb
@@ -0,0 +1,50 @@
1require ruby.inc
2PR = "${INC_PR}.0"
3
4SRC_URI += "\
5 file://0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch \
6 file://ruby-1.9.3-always-use-i386.patch \
7 file://ruby-1.9.3-disable-versioned-paths.patch \
8 file://ruby-1.9.3-rubygems-1.8.11-uninstaller.patch \
9 file://ruby-1.9.3-custom-rubygems-location.patch \
10 file://rubygems-1.8.11-binary-extensions.patch \
11 file://ruby-1.9.3-mkmf-verbose.patch \
12 file://ruby-1.9.3-install-cross.patch \
13 file://remove-the-dependency-on-dir.patch \
14 file://ruby-mkmf.rb-fix-race-conditions-at-install-ext.patch \
15"
16SRC_URI[md5sum] = "7531f9b1b35b16f3eb3d7bea786babfd"
17SRC_URI[sha256sum] = "9ba118e4aba04c430bc4d5efb09b31a0277e101c9fd2ef3b80b9c684d7ae57a1"
18
19# it's unknown to configure script, but then passed to extconf.rb
20# maybe it's not really needed as we're hardcoding the result with
21# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
22UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
23
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
26
27EXTRA_OECONF = "\
28 --enable-wide-getaddrinfo \
29 --disable-versioned-paths \
30 --disable-rpath \
31 --enable-shared \
32 --enable-load-relative \
33"
34
35EXTRA_OEMAKE = " \
36 LIBRUBYARG='-lruby-static' \
37"
38
39do_install() {
40 oe_runmake 'DESTDIR=${D}' install
41}
42
43FILES_${PN} += "${datadir}/rubygems \
44 ${datadir}/ri"
45
46FILES_${PN}-dbg += "${libdir}/ruby/*/.debug \
47 ${libdir}/ruby/*/*/.debug \
48 ${libdir}/ruby/*/*/*/.debug"
49
50BBCLASSEXTEND = "native"