summaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/ruby')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch31
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/extmk.patch13
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch15
3 files changed, 59 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch b/meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
new file mode 100644
index 000000000..64f093a4f
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby/0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
@@ -0,0 +1,31 @@
1From 9341293e71c03fe606edc9157bf1e13e3dd5b507 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 17 Dec 2010 11:35:38 +0100
4Subject: [PATCH] socket extconf: hardcode wide-getaddr info test outcome to true
5
6Without this the socket extension doesn't build correctly
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 ext/socket/extconf.rb | 5 +++++
11 1 files changed, 5 insertions(+), 0 deletions(-)
12
13diff --git a/ext/socket/extconf.rb b/ext/socket/extconf.rb
14index ece6158..5fba46c 100644
15--- a/ext/socket/extconf.rb
16+++ b/ext/socket/extconf.rb
17@@ -222,6 +222,11 @@ main()
18 exit(EXIT_FAILURE);
19 }
20 EOF
21+
22+# Ignore the actual result of the above test and assume that
23+# everything is OK.
24+getaddr_info_ok = true
25+
26 end
27 if ipv6 and not getaddr_info_ok
28 abort <<EOS
29--
301.6.6.1
31
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/extmk.patch b/meta-ruby/recipes-devtools/ruby/ruby/extmk.patch
new file mode 100644
index 000000000..8b6845034
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby/extmk.patch
@@ -0,0 +1,13 @@
1diff -ru ruby-1.8.7-p248.orig/ext/extmk.rb ruby-1.8.7-p248/ext/extmk.rb
2--- ruby-1.8.7-p248.orig/ext/extmk.rb 2009-12-24 03:01:58.000000000 -0600
3+++ ruby-1.8.7-p248/ext/extmk.rb 2010-02-12 15:55:27.370061558 -0600
4@@ -354,8 +354,8 @@
5 $ruby = '$(topdir)/miniruby' + EXEEXT
6 end
7 $ruby << " -I'$(topdir)'"
8+$ruby << " -I'$(top_srcdir)/lib'"
9 unless CROSS_COMPILING
10- $ruby << " -I'$(top_srcdir)/lib'"
11 $ruby << " -I'$(extout)/$(arch)' -I'$(extout)/common'" if $extout
12 $ruby << " -I./- -I'$(top_srcdir)/ext' -rpurelib.rb"
13 ENV["RUBYLIB"] = "-"
diff --git a/meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch b/meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch
new file mode 100644
index 000000000..57926f51b
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby/extmk_run.patch
@@ -0,0 +1,15 @@
1============================================================
2--- packages/ruby/ruby-1.8.5/extmk_run.patch d9738b5a71e2f9a98d009af9fd0ef1ceaff9ef48
3+++ packages/ruby/ruby-1.8.5/extmk_run.patch d9738b5a71e2f9a98d009af9fd0ef1ceaff9ef48
4@@ -0,0 +1,11 @@
5+--- ruby-1.8.5/common.mk.orig 2006-12-30 13:07:32.000000000 +1100
6++++ ruby-1.8.5/common.mk 2006-12-30 13:08:32.000000000 +1100
7+@@ -56,7 +56,7 @@
8+ --make="$(MAKE)" \
9+ --mflags="$(MFLAGS)" \
10+ --make-flags="$(MAKEFLAGS)"
11+-EXTMK_ARGS = $(SCRIPT_ARGS) --extout="$(EXTOUT)" --extension $(EXTS) --extstatic $(EXTSTATIC) --
12++EXTMK_ARGS = $(SCRIPT_ARGS) --with-ldflags="%%TARGET_LDFLAGS%%" --with-cflags="%%TARGET_CFLAGS%%" --extout="$(EXTOUT)" --extension $(EXTS) --extstatic $(EXTSTATIC) --
13+
14+ all: $(MKFILES) $(PREP) $(RBCONFIG) $(LIBRUBY)
15+ @$(MINIRUBY) $(srcdir)/ext/extmk.rb $(EXTMK_ARGS)