summaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/ruby.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/ruby.inc')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
deleted file mode 100644
index ba6019107..000000000
--- a/meta-ruby/recipes-devtools/ruby/ruby.inc
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "An interpreter of object-oriented scripting language"
2DESCRIPTION = "Ruby is an interpreted scripting language for quick \
3and easy object-oriented programming. It has many features to process \
4text files and to do system management tasks (as in Perl). \
5It is simple, straight-forward, and extensible. \
6"
7HOMEPAGE = "http://www.ruby-lang.org/"
8SECTION = "devel/ruby"
9LICENSE = "Ruby | BSD | GPLv2"
10LIC_FILES_CHKSUM = "\
11 file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \
12 file://BSDL;md5=19aaf65c88a40b508d17ae4be539c4b5\
13 file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263\
14 file://LEGAL;md5=c440adb575ba4e6e2344c2630b6a5584\
15"
16
17DEPENDS = "ruby-native zlib openssl tcl libyaml db gdbm readline"
18DEPENDS_class-native = "libyaml-native"
19
20SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
21SRC_URI = "http://cache.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
22 file://extmk.patch \
23"
24
25S = "${WORKDIR}/ruby-${PV}"
26
27inherit autotools
28
29
30# This snippet lets compiled extensions which rely on external libraries,
31# such as zlib, compile properly. If we don't do this, then when extmk.rb
32# runs, it uses the native libraries instead of the target libraries, and so
33# none of the linking operations succeed -- which makes extconf.rb think
34# that the libraries aren't available and hence that the extension can't be
35# built.
36
37do_configure_prepend() {
38 sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
39 rm -rf ${S}/ruby/
40}