summaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/ruby.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/ruby.inc')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
new file mode 100644
index 000000000..770286960
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/ruby.inc
@@ -0,0 +1,42 @@
1SUMMARY = "An interpreter of object-oriented scripting language"
2DESCRIPTION = "Ruby is an interpreted scripting language for quick \
3and easy object-oriented programming. It has many features to process \
4text files and to do system management tasks (as in Perl). \
5It is simple, straight-forward, and extensible. \
6"
7HOMEPAGE = "http://www.ruby-lang.org/"
8SECTION = "devel/ruby"
9LICENSE = "Ruby | BSD | GPLv2"
10LIC_FILES_CHKSUM = "\
11 file://COPYING;md5=837b32593517ae48b9c3b5c87a5d288c \
12 file://BSDL;md5=3949e007205deef714bd225e1ee4a8ea \
13 file://GPL;md5=393a5ca445f6965873eca0259a17f833 \
14 file://LEGAL;md5=3ce1fae39fe573b818c0af162bce6579 \
15"
16
17DEPENDS = "ruby-native zlib openssl tcl libyaml db gdbm readline"
18DEPENDS_class-native = "libyaml-native"
19
20INC_PR = "r1"
21
22SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
23SRC_URI = "http://cache.ruby-lang.org/pub/ruby/${SHRT_VER}/ruby-${PV}.tar.gz \
24 file://extmk.patch \
25"
26
27S = "${WORKDIR}/ruby-${PV}"
28
29inherit autotools
30
31
32# This snippet lets compiled extensions which rely on external libraries,
33# such as zlib, compile properly. If we don't do this, then when extmk.rb
34# runs, it uses the native libraries instead of the target libraries, and so
35# none of the linking operations succeed -- which makes extconf.rb think
36# that the libraries aren't available and hence that the extension can't be
37# built.
38
39do_configure_prepend() {
40 sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
41 rm -rf ${S}/ruby/
42}