summaryrefslogtreecommitdiffstats
path: root/meta-ruby/recipes-devtools/ruby/bundler_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ruby/recipes-devtools/ruby/bundler_git.bb')
-rw-r--r--meta-ruby/recipes-devtools/ruby/bundler_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/bundler_git.bb b/meta-ruby/recipes-devtools/ruby/bundler_git.bb
new file mode 100644
index 000000000..2adde4d21
--- /dev/null
+++ b/meta-ruby/recipes-devtools/ruby/bundler_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Makes sure Ruby applications run the same code on every machine."
2DESCRIPTION = "Bundler makes sure Ruby applications run the same code \
3on every machine. It does this by managing the gems that the \
4application depends on. Given a list of gems, it can automatically \
5download and install those gems, as well as any other gems needed by \
6the gems that are listed. Before installing gems, it checks the \
7versions of every gem to make sure that they are compatible, and can \
8all be loaded at the same time. After the gems have been installed, \
9Bundler can help you update some or all of them when new versions \
10become available. Finally, it records the exact versions that have \
11been installed, so that others can install the exact same gems."
12
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://LICENSE.md;md5=196bb963e601609817d7e9ac9a64a867"
15
16PR = "r0"
17
18PV = "1.6.2"
19SRCREV = "06e3647c117da210ffd15a174624497830addd7b"
20
21S = "${WORKDIR}/git"
22
23SRC_URI = " \
24 git://github.com/bundler/bundler.git \
25 "
26
27inherit ruby
28
29BBCLASSEXTEND = "native"