diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-scrypt.inc | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch (renamed from meta-python/recipes-devtools/python/python-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch) | 0 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb | 25 |
3 files changed, 23 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python-scrypt.inc b/meta-python/recipes-devtools/python/python-scrypt.inc deleted file mode 100644 index aa9d7b8d4..000000000 --- a/meta-python/recipes-devtools/python/python-scrypt.inc +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" | ||
2 | LICENSE = "BSD-2-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc" | ||
4 | HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview" | ||
5 | |||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-scrypt:" | ||
7 | |||
8 | SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56" | ||
11 | SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d" | ||
12 | |||
13 | inherit pypi ptest | ||
14 | |||
15 | SRC_URI += " \ | ||
16 | file://run-ptest \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS_${PN}-ptest += " \ | ||
20 | ${PYTHON_PN}-pytest \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/tests | ||
25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
26 | } | ||
27 | |||
28 | RDEPENDS_${PN}_class-target += "\ | ||
29 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch b/meta-python/recipes-devtools/python/python3-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch index d535e4326..d535e4326 100644 --- a/meta-python/recipes-devtools/python/python-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch +++ b/meta-python/recipes-devtools/python/python3-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch | |||
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb index f49665322..7588fc54b 100644 --- a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb +++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb | |||
@@ -1,3 +1,24 @@ | |||
1 | inherit setuptools3 python3-dir | 1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" |
2 | require python-scrypt.inc | 2 | LICENSE = "BSD-2-Clause" |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc" | ||
4 | HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview" | ||
3 | 5 | ||
6 | SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch" | ||
7 | |||
8 | SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56" | ||
9 | SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d" | ||
10 | |||
11 | inherit pypi ptest setuptools3 | ||
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS_${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | " | ||
20 | |||
21 | do_install_ptest() { | ||
22 | install -d ${D}${PTEST_PATH}/tests | ||
23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
24 | } | ||