summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb24
2 files changed, 24 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb
deleted file mode 100644
index d809d9718..000000000
--- a/meta-python/recipes-devtools/python/python-pyroute2_0.3.12.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "A pure Python netlink and Linux network configuration library"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=270323035ef766597dabd91747c36e3d"
4
5SRC_URI[md5sum] = "5d83ec82acb54ab88c98f0d25d13308b"
6SRC_URI[sha256sum] = "c0e1637a75e099104f14d9e03fd5a698dfcc923a22fbfac4a19bd7e94d1fcaa5"
7
8SRC_URI += "file://import-simplejson-as-json.patch"
9
10inherit pypi
11
12RDEPENDS_${PN} = "python-distutils \
13 python-simplejson \
14 "
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb
new file mode 100644
index 000000000..3fc51429c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyroute2_0.3.14.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "A pure Python netlink and Linux network configuration library"
2LICENSE = "GPLv2 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.Apache.v2;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRC_URI[md5sum] = "1e7e771702056e61cf522cccc39ea09e"
7SRC_URI[sha256sum] = "aed742a7dbe55eb7f02dbb26719f554b9e92198c4b3c7ac501ad03bbb6421962"
8
9SRC_URI += "file://import-simplejson-as-json.patch"
10
11inherit pypi
12
13RDEPENDS_${PN} += "\
14 python-distutils \
15 python-simplejson \
16 python-multiprocessing \
17 python-io python-pprint \
18 python-pickle \
19 python-logging \
20 python-threading \
21 python-textutils \
22 python-subprocess \
23 python-netclient \
24"