diff options
Diffstat (limited to 'meta-python')
3 files changed, 26 insertions, 4 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc index ec26f768e..ccb443182 100644 --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc | |||
@@ -40,6 +40,7 @@ PTESTS_FAST_META_PYTHON = "\ | |||
40 | python3-parse-type \ | 40 | python3-parse-type \ |
41 | python3-platformdirs \ | 41 | python3-platformdirs \ |
42 | python3-polyline \ | 42 | python3-polyline \ |
43 | python3-portalocker \ | ||
43 | python3-precise-runner \ | 44 | python3-precise-runner \ |
44 | python3-prettytable \ | 45 | python3-prettytable \ |
45 | python3-pydantic \ | 46 | python3-pydantic \ |
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest b/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest new file mode 100644 index 000000000..8d2017d39 --- /dev/null +++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb index 69578ba84..c45a3fcda 100644 --- a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb +++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb | |||
@@ -8,11 +8,29 @@ SRC_URI[sha256sum] = "2b035aa7828e46c58e9b31390ee1f169b98e1066ab10b9a6a861fe7e25 | |||
8 | 8 | ||
9 | DEPENDS += "python3-setuptools-scm-native" | 9 | DEPENDS += "python3-setuptools-scm-native" |
10 | 10 | ||
11 | inherit pypi python_setuptools_build_meta | 11 | inherit pypi python_setuptools_build_meta ptest |
12 | 12 | ||
13 | BBCLASSEXTEND = "native nativesdk" | 13 | SRC_URI += " \ |
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS:${PN}-ptest += " \ | ||
18 | python3-multiprocessing \ | ||
19 | python3-pytest \ | ||
20 | python3-redis \ | ||
21 | python3-unittest-automake-output \ | ||
22 | redis \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | cp -rf ${S}/portalocker_tests/* ${D}${PTEST_PATH}/tests/ | ||
28 | rm -rf ${D}${PTEST_PATH}/tests/test_combined.py | ||
29 | } | ||
14 | 30 | ||
15 | RDEPENDS:${PN} += " \ | 31 | RDEPENDS:${PN} += " \ |
16 | python3-fcntl \ | 32 | python3-fcntl \ |
17 | python3-logging \ | 33 | python3-logging \ |
18 | " | 34 | " |
35 | |||
36 | BBCLASSEXTEND = "native nativesdk" | ||