diff options
Diffstat (limited to 'meta-python')
3 files changed, 62 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb new file mode 100644 index 000000000..a9b64ed13 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cryptography-vectors_0.8.1.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "Test vectors for the cryptography package." | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "Apache-2.0 | BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4" | ||
5 | DEPENDS = "python-cryptography" | ||
6 | SRCNAME = "cryptography_vectors" | ||
7 | |||
8 | SRC_URI = "https://pypi.python.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz" | ||
9 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
10 | |||
11 | SRC_URI[md5sum] = "04fcfcc61aee62e3b4beb1740cd120ac" | ||
12 | SRC_URI[sha256sum] = "4a69e66026bfce4b97f75e72fe262f5e8f71daddc081f6608e5b0db89e552504" | ||
13 | |||
14 | inherit setuptools | ||
diff --git a/meta-python/recipes-devtools/python/python-cryptography/run-ptest b/meta-python/recipes-devtools/python/python-cryptography/run-ptest new file mode 100644 index 000000000..0ba239c2a --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cryptography/run-ptest | |||
@@ -0,0 +1,2 @@ | |||
1 | #!/bin/sh | ||
2 | py.test | ||
diff --git a/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb b/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb new file mode 100644 index 000000000..41e4acdb5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cryptography_0.8.1.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SUMMARY = "Provides cryptographic recipes and primitives to Python developers" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "Apache-2.0 | BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4" | ||
5 | DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1" | ||
6 | SRCNAME = "cryptography" | ||
7 | |||
8 | SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ | ||
9 | file://run-ptest \ | ||
10 | " | ||
11 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
12 | |||
13 | SRC_URI[md5sum] = "70dde78a5515abdbfd7a3d58f15689ab" | ||
14 | SRC_URI[sha256sum] = "f4e041bc83c1be94d87116a7aa201c378b7c6581be4d83994b2da0a84499f73b" | ||
15 | |||
16 | inherit pypi | ||
17 | |||
18 | RDEPENDS_${PN} = "\ | ||
19 | python-pyasn1\ | ||
20 | python-six\ | ||
21 | python-cffi\ | ||
22 | python-enum34\ | ||
23 | python-setuptools\ | ||
24 | python-pycparser\ | ||
25 | python-subprocess\ | ||
26 | python-threading\ | ||
27 | python-numbers\ | ||
28 | python-contextlib\ | ||
29 | " | ||
30 | |||
31 | RDEPENDS_${PN}-ptest = "\ | ||
32 | ${PN}\ | ||
33 | python-pytest\ | ||
34 | python-pretend\ | ||
35 | python-iso8601\ | ||
36 | python-cryptography-vectors\ | ||
37 | " | ||
38 | |||
39 | inherit ptest | ||
40 | |||
41 | do_install_ptest() { | ||
42 | install -d ${D}${PTEST_PATH}/tests | ||
43 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
44 | install -d ${D}${PTEST_PATH}/tests/hazmat | ||
45 | cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ | ||
46 | } | ||