summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc26
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb6
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
new file mode 100644
index 000000000..3466457e0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -0,0 +1,26 @@
1SUMMARY = "An implementation of JSON Schema validation for Python"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8"
4
5SRC_URI[md5sum] = "374e848fdb69a3ce8b7e778b47c30640"
6SRC_URI[sha256sum] = "36673ac378feed3daa5956276a829699056523d7961027911f064b52255ead41"
7
8RDEPENDS_${PN} += " \
9 ${PYTHON_PN}-core \
10 ${PYTHON_PN}-io \
11 ${PYTHON_PN}-json \
12 ${PYTHON_PN}-lang \
13 ${PYTHON_PN}-netclient \
14 ${PYTHON_PN}-numbers \
15 ${PYTHON_PN}-pkgutil \
16 ${PYTHON_PN}-pprint \
17 ${PYTHON_PN}-re \
18 ${PYTHON_PN}-rfc3987 \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-strict-rfc3339 \
21 ${PYTHON_PN}-subprocess \
22 ${PYTHON_PN}-textutils \
23 ${PYTHON_PN}-unittest \
24"
25
26BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb
new file mode 100644
index 000000000..3bb522018
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb
@@ -0,0 +1,8 @@
1inherit pypi setuptools
2require python-jsonschema.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-argparse \
6 ${PYTHON_PN}-contextlib \
7 ${PYTHON_PN}-functools32 \
8"
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
new file mode 100644
index 000000000..5aaee682b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
@@ -0,0 +1,6 @@
1inherit pypi setuptools3
2require python-jsonschema.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-misc \
6"