summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pybluez.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-pybluez_0.22.bb19
-rw-r--r--meta-python/recipes-devtools/python/python3-pybluez_0.22.bb2
3 files changed, 21 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-pybluez.inc b/meta-python/recipes-devtools/python/python-pybluez.inc
new file mode 100644
index 000000000..ed72716b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pybluez.inc
@@ -0,0 +1,17 @@
1DESCRIPTION = "Bluetooth Python extension module"
2HOMEPAGE = "http://karulis.github.io/pybluez/"
3SECTION = "devel/python"
4
5RDEPENDS_${PN} = "bluez5"
6DEPENDS = "bluez5"
7
8LICENSE = "GPL-2.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
10
11inherit pypi
12
13SRC_URI = "https://pypi.python.org/packages/c1/98/3149481d508bee174335be6725880f00d297afebe75c15e917af8f6fe169/PyBluez-0.22.zip"
14SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
15SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
16
17S = "${WORKDIR}/PyBluez-${PV}"
diff --git a/meta-python/recipes-devtools/python/python-pybluez_0.22.bb b/meta-python/recipes-devtools/python/python-pybluez_0.22.bb
index eab9c5420..3158f4b64 100644
--- a/meta-python/recipes-devtools/python/python-pybluez_0.22.bb
+++ b/meta-python/recipes-devtools/python/python-pybluez_0.22.bb
@@ -1,17 +1,2 @@
1DESCRIPTION = "Bluetooth Python extension module" 1require python-pybluez.inc
2HOMEPAGE = "http://karulis.github.io/pybluez/" 2inherit setuptools
3SECTION = "devel/python"
4
5RDEPENDS_${PN} = "bluez5"
6DEPENDS = "bluez5"
7
8LICENSE = "GPL-2.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
10
11inherit pypi setuptools
12
13SRC_URI = "https://pypi.python.org/packages/c1/98/3149481d508bee174335be6725880f00d297afebe75c15e917af8f6fe169/PyBluez-0.22.zip"
14SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
15SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
16
17S = "${WORKDIR}/PyBluez-${PV}"
diff --git a/meta-python/recipes-devtools/python/python3-pybluez_0.22.bb b/meta-python/recipes-devtools/python/python3-pybluez_0.22.bb
new file mode 100644
index 000000000..9712a7608
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybluez_0.22.bb
@@ -0,0 +1,2 @@
1require python-pybluez.inc
2inherit setuptools3