diff options
Diffstat (limited to 'meta-python')
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc new file mode 100644 index 000000000..54dd49f1f --- /dev/null +++ b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "A simple connection pool for gevent" | ||
2 | DESCRIPTION = "creates a pool of connections that can be used with gevent" | ||
3 | HOMEPAGE = "https://github.com/studio-ousia/gsocketpool" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859" | ||
6 | DEPENDS += "${PYTHON_PN}-gevent" | ||
7 | RDEPENDS_${PN} += "${PYTHON_PN}-gevent" | ||
8 | |||
9 | SRC_URI_append = " \ | ||
10 | file://0001-fix_setup_py.patch;patch=1;pnum=1 \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "04f618864b18d6b06f774994f172ef49" | ||
14 | SRC_URI[sha256sum] = "b6b73deab9bcbc428d4813697eebe5c3b9c40a971f62e13607b881aa749af9d0" | ||
15 | |||
16 | inherit pypi | ||
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb index f86152c4a..e96ad1ca1 100644 --- a/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb +++ b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb | |||
@@ -1,16 +1,2 @@ | |||
1 | SUMMARY = "A simple connection pool for gevent" | 1 | require python-gsocketpool.inc |
2 | DESCRIPTION = "creates a pool of connections that can be used with gevent" | 2 | inherit setuptools |
3 | HOMEPAGE = "https://github.com/studio-ousia/gsocketpool" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859" | ||
6 | DEPENDS += "python-gevent" | ||
7 | RDEPENDS_${PN} += "python-gevent" | ||
8 | |||
9 | SRC_URI_append = " \ | ||
10 | file://0001-fix_setup_py.patch;patch=1;pnum=1 \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "04f618864b18d6b06f774994f172ef49" | ||
14 | SRC_URI[sha256sum] = "b6b73deab9bcbc428d4813697eebe5c3b9c40a971f62e13607b881aa749af9d0" | ||
15 | |||
16 | inherit pypi setuptools | ||
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb b/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb new file mode 100644 index 000000000..883621e21 --- /dev/null +++ b/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-gsocketpool.inc | ||
2 | inherit setuptools3 | ||