summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-systemd_234.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-systemd_234.bb13
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd_234.bb b/meta-python/recipes-devtools/python/python-systemd_234.bb
new file mode 100644
index 000000000..ef1183171
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-systemd_234.bb
@@ -0,0 +1,13 @@
1SUMMARY = "Python interface for libsystemd"
2HOMEPAGE = "https://github.com/systemd/python-systemd"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
8RDEPENDS_${PN} += "systemd"
9REQUIRED_DISTRO_FEATURES = "systemd"
10inherit pypi setuptools distro_features_check
11
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_234.bb
new file mode 100644
index 000000000..845b7d9e1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-systemd_234.bb
@@ -0,0 +1,13 @@
1SUMMARY = "Python interface for libsystemd"
2HOMEPAGE = "https://github.com/systemd/python-systemd"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
8RDEPENDS_${PN} += "systemd"
9REQUIRED_DISTRO_FEATURES = "systemd"
10inherit pypi setuptools3 distro_features_check
11
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"