summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb3
3 files changed, 19 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt.inc b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
new file mode 100644
index 000000000..7ff3fb242
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
@@ -0,0 +1,14 @@
1SUMMARY = "MQTT version 3.1/3.1.1 client library"
2LICENSE = "EPL-1.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
4SRCNAME = "paho-mqtt"
5
6inherit pypi
7SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1"
8SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f"
9
10RDEPENDS_${PN} = "\
11 ${PYTHON_PN}-math \
12 ${PYTHON_PN}-io \
13 ${PYTHON_PN}-threading \
14"
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb b/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb
index c8acfc557..f369b2e84 100644
--- a/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt_1.2.bb
@@ -1,15 +1,3 @@
1SUMMARY = "MQTT version 3.1/3.1.1 client library" 1inherit setuptools
2LICENSE = "EPL-1.0" 2require python-paho-mqtt.inc
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc"
4SRCNAME = "paho-mqtt"
5 3
6inherit pypi setuptools
7
8RDEPENDS_${PN} = "\
9 python-math \
10 python-io \
11 python-threading \
12"
13
14SRC_URI[md5sum] = "241150b3fcb920ddca4d33181f3238b1"
15SRC_URI[sha256sum] = "9100a6aa706ab699d414ec02705a21eb66f436184691d0bf1f2a85a6213c6c1f"
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb
new file mode 100644
index 000000000..4981e61ed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.2.bb
@@ -0,0 +1,3 @@
1inherit setuptools3
2require python-paho-mqtt.inc
3