summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb7
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-simplejson.inc b/meta-python/recipes-devtools/python/python-simplejson.inc
new file mode 100644
index 000000000..2eed19965
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-simplejson.inc
@@ -0,0 +1,17 @@
1SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
6
7SRC_URI[md5sum] = "426a9631d22851a7a970b1a677368b15"
8SRC_URI[sha256sum] = "953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2"
9
10inherit pypi
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-re \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-netserver \
16 ${PYTHON_PN}-numbers \
17"
diff --git a/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb
new file mode 100644
index 000000000..e33edfeba
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-simplejson_3.10.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-simplejson.inc
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb
new file mode 100644
index 000000000..d44bc1526
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.10.0.bb
@@ -0,0 +1,7 @@
1inherit setuptools3
2require python-simplejson.inc
3
4# Requires _pydecimal which is in misc
5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-misc \
7"