summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-unidiff/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-unidiff_0.7.5.bb7
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-unidiff/run-ptest b/meta-python/recipes-devtools/python/python3-unidiff/run-ptest
index b63c4de0d..8d2017d39 100644
--- a/meta-python/recipes-devtools/python/python3-unidiff/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-unidiff/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-unidiff_0.7.5.bb b/meta-python/recipes-devtools/python/python3-unidiff_0.7.5.bb
index 690acf863..d77252bea 100644
--- a/meta-python/recipes-devtools/python/python3-unidiff_0.7.5.bb
+++ b/meta-python/recipes-devtools/python/python3-unidiff_0.7.5.bb
@@ -12,7 +12,8 @@ SRC_URI += " \
12" 12"
13 13
14RDEPENDS:${PN}-ptest += " \ 14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \ 15 python3-pytest \
16 python3-unittest-automake-output \
16" 17"
17 18
18do_install_ptest() { 19do_install_ptest() {
@@ -21,6 +22,6 @@ do_install_ptest() {
21} 22}
22 23
23RDEPENDS:${PN} += " \ 24RDEPENDS:${PN} += " \
24 ${PYTHON_PN}-codecs \ 25 python3-codecs \
25 ${PYTHON_PN}-io \ 26 python3-io \
26" 27"