summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-twisted_13.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-python/python/python-twisted_13.2.0.bb')
-rw-r--r--meta-python/recipes-python/python/python-twisted_13.2.0.bb222
1 files changed, 222 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-twisted_13.2.0.bb b/meta-python/recipes-python/python/python-twisted_13.2.0.bb
new file mode 100644
index 000000000..80d64a019
--- /dev/null
+++ b/meta-python/recipes-python/python/python-twisted_13.2.0.bb
@@ -0,0 +1,222 @@
1DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
3(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4HOMEPAGE = "http://www.twistedmatrix.com"
5SECTION = "console/network"
6
7#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5602d7228daf59a16f0f1b2640c46bca"
10
11SRC_URI = "https://pypi.python.org/packages/source/T/Twisted/Twisted-${PV}.tar.bz2"
12SRC_URI[md5sum] = "83fe6c0c911cc1602dbffb036be0ba79"
13SRC_URI[sha256sum] = "095175638c019ac7c0604f4c291724a16ff1acd062e181b01293bf4dcbc62cf3"
14
15S = "${WORKDIR}/Twisted-${PV}"
16
17inherit setuptools
18
19do_install_append() {
20 # remove some useless files before packaging
21 find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
22}
23
24PACKAGES += "\
25 ${PN}-zsh \
26 ${PN}-test \
27 ${PN}-protocols \
28 ${PN}-conch \
29 ${PN}-lore \
30 ${PN}-mail \
31 ${PN}-names \
32 ${PN}-news \
33 ${PN}-runner \
34 ${PN}-web \
35 ${PN}-words \
36 ${PN}-flow \
37 ${PN}-pair \
38 ${PN}-core \
39"
40
41RDEPENDS_${PN} = "python-core python-zopeinterface"
42RDEPENDS_${PN} += "\
43 ${PN}-conch \
44 ${PN}-lore \
45 ${PN}-mail \
46 ${PN}-names \
47 ${PN}-news \
48 ${PN}-runner \
49 ${PN}-web \
50 ${PN}-words \
51"
52
53ALLOW_EMPTY_${PN} = "1"
54FILES_${PN} = ""
55
56FILES_${PN}-test = " \
57 ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
58 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
59"
60
61FILES_${PN}-protocols = " \
62 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \
63 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \
64 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \
65"
66
67FILES_${PN}-zsh = " \
68 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
69 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
70 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \
71"
72
73FILES_${PN}-conch = " \
74 ${bindir}/ckeygen \
75 ${bindir}/tkconch \
76 ${bindir}/conch \
77 ${bindir}/conchftp \
78 ${bindir}/cftp \
79 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
80 ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
81"
82
83FILES_${PN}-core = " \
84${bindir}/manhole \
85${bindir}/mktap \
86${bindir}/twistd \
87${bindir}/tap2deb \
88${bindir}/tap2rpm \
89${bindir}/tapconvert \
90${bindir}/tkmktap \
91${bindir}/trial \
92${bindir}/easy_install* \
93${bindir}/pyhtmlizer \
94${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \
95${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
96${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
97${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
98${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
99${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
100${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
101${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
102${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
103${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
104${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
105${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
106${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
107${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
108${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
109${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
110${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
111${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
112${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
113${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
114${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
115${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
116${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
117${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
118${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
119${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
120${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
121${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
122${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
123${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
124${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
125${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
126${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
127${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
128${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
129${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
130${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
131${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
132${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
133${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
134${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
135${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
136${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
137${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
138${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
139${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
140${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
141${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
142${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
143${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
144${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
145${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
146${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
147${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
148${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
149${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
150${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
151${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
152${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
153${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
154${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
155${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
156${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
157${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
158${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
159${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
160${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
161${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
162${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
163${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
164${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
165${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
166${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
167"
168
169FILES_${PN}-lore = " \
170${bindir}/bookify \
171${bindir}/lore \
172${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \
173${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \
174"
175
176FILES_${PN}-mail = " \
177${bindir}/mailmail \
178${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
179${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
180"
181
182FILES_${PN}-names = " \
183${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
184${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
185"
186
187FILES_${PN}-news = " \
188${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
189${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
190"
191
192FILES_${PN}-runner = " \
193${libdir}/site-packages/twisted/runner/portmap.so \
194${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
195"
196
197FILES_${PN}-web = " \
198${bindir}/websetroot \
199${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
200${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
201"
202
203FILES_${PN}-words = " \
204${bindir}/im \
205${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
206${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
207"
208
209FILES_${PN}-flow = " \
210${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
211${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
212
213FILES_${PN}-pair = " \
214${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
215${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
216"
217
218FILES_${PN}-dbg += " \
219${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
220${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
221"
222