diff options
Diffstat (limited to 'meta-python/recipes-extended')
14 files changed, 48 insertions, 121 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch index c77b86a45..90fa387b0 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 648a18bfc447f076d48ae4147d984b8ef56e37aa Mon Sep 17 00:00:00 2001 | 1 | From fc8e93530ba017ecfe111e53d3cbdc3a5b3ac286 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Mon, 30 Jul 2018 16:13:40 +0800 | 3 | Date: Fri, 23 Nov 2018 16:58:38 +0800 |
4 | Subject: [PATCH 01/11] comment out selinux | 4 | Subject: [PATCH 01/11] comment out selinux |
5 | 5 | ||
6 | Upstream-Status: Inappropriate [oe specific] | 6 | Upstream-Status: Inappropriate [oe specific] |
@@ -12,7 +12,7 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
12 | 2 files changed, 8 insertions(+), 3 deletions(-) | 12 | 2 files changed, 8 insertions(+), 3 deletions(-) |
13 | 13 | ||
14 | diff --git a/blivet/flags.py b/blivet/flags.py | 14 | diff --git a/blivet/flags.py b/blivet/flags.py |
15 | index 1840121..8789390 100644 | 15 | index 4e26d82..94324ff 100644 |
16 | --- a/blivet/flags.py | 16 | --- a/blivet/flags.py |
17 | +++ b/blivet/flags.py | 17 | +++ b/blivet/flags.py |
18 | @@ -20,7 +20,7 @@ | 18 | @@ -20,7 +20,7 @@ |
@@ -35,7 +35,7 @@ index 1840121..8789390 100644 | |||
35 | self.dmraid = True | 35 | self.dmraid = True |
36 | self.ibft = True | 36 | self.ibft = True |
37 | diff --git a/blivet/util.py b/blivet/util.py | 37 | diff --git a/blivet/util.py b/blivet/util.py |
38 | index 7334ff6..0f2a995 100644 | 38 | index 9daf151..4eac8b9 100644 |
39 | --- a/blivet/util.py | 39 | --- a/blivet/util.py |
40 | +++ b/blivet/util.py | 40 | +++ b/blivet/util.py |
41 | @@ -3,7 +3,7 @@ import functools | 41 | @@ -3,7 +3,7 @@ import functools |
@@ -47,7 +47,7 @@ index 7334ff6..0f2a995 100644 | |||
47 | import subprocess | 47 | import subprocess |
48 | import re | 48 | import re |
49 | import sys | 49 | import sys |
50 | @@ -430,6 +430,8 @@ def get_cow_sysfs_path(dev_path, dev_sysfsPath): | 50 | @@ -444,6 +444,8 @@ def get_cow_sysfs_path(dev_path, dev_sysfsPath): |
51 | def match_path_context(path): | 51 | def match_path_context(path): |
52 | """ Return the default SELinux context for the given path. """ | 52 | """ Return the default SELinux context for the given path. """ |
53 | context = None | 53 | context = None |
@@ -56,7 +56,7 @@ index 7334ff6..0f2a995 100644 | |||
56 | try: | 56 | try: |
57 | context = selinux.matchpathcon(os.path.normpath(path), 0)[1] | 57 | context = selinux.matchpathcon(os.path.normpath(path), 0)[1] |
58 | except OSError as e: | 58 | except OSError as e: |
59 | @@ -454,6 +456,8 @@ def set_file_context(path, context, root=None): | 59 | @@ -468,6 +470,8 @@ def set_file_context(path, context, root=None): |
60 | 60 | ||
61 | True if successful, False if not. | 61 | True if successful, False if not. |
62 | """ | 62 | """ |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch index fea225407..5b388599b 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch | |||
@@ -1,20 +1,20 @@ | |||
1 | From 596979ed58109141a7fee680ab95b27296c022b1 Mon Sep 17 00:00:00 2001 | 1 | From 713cf821ebe17f9e1771502a85e0905ea04dafae Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Mon, 8 May 2017 14:39:56 +0800 | 3 | Date: Fri, 23 Nov 2018 17:03:58 +0800 |
4 | Subject: [PATCH 02/11] run_program support timeout | 4 | Subject: [PATCH 02/11] run_program support timeout |
5 | 5 | ||
6 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
7 | 7 | ||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
9 | --- | 9 | --- |
10 | blivet/util.py | 68 +++++++++++++++++++++++++++++++++------------------------- | 10 | blivet/util.py | 70 ++++++++++++++++++++++++++++++++++------------------------ |
11 | 1 file changed, 39 insertions(+), 29 deletions(-) | 11 | 1 file changed, 41 insertions(+), 29 deletions(-) |
12 | 12 | ||
13 | diff --git a/blivet/util.py b/blivet/util.py | 13 | diff --git a/blivet/util.py b/blivet/util.py |
14 | index 0f2a995..05a253c 100644 | 14 | index 4eac8b9..4f05076 100644 |
15 | --- a/blivet/util.py | 15 | --- a/blivet/util.py |
16 | +++ b/blivet/util.py | 16 | +++ b/blivet/util.py |
17 | @@ -157,6 +157,30 @@ class Path(str): | 17 | @@ -158,6 +158,30 @@ class Path(str): |
18 | def __hash__(self): | 18 | def __hash__(self): |
19 | return self._path.__hash__() | 19 | return self._path.__hash__() |
20 | 20 | ||
@@ -45,12 +45,12 @@ index 0f2a995..05a253c 100644 | |||
45 | 45 | ||
46 | def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=False, binary_output=False): | 46 | def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=False, binary_output=False): |
47 | if env_prune is None: | 47 | if env_prune is None: |
48 | @@ -179,36 +203,22 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa | 48 | @@ -180,35 +204,23 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa |
49 | stderr_dir = subprocess.STDOUT | 49 | stderr_dir = subprocess.STDOUT |
50 | else: | 50 | else: |
51 | stderr_dir = subprocess.PIPE | 51 | stderr_dir = subprocess.PIPE |
52 | - try: | 52 | - try: |
53 | - proc = subprocess.Popen(argv, | 53 | - proc = subprocess.Popen(argv, # pylint: disable=subprocess-popen-preexec-fn |
54 | - stdin=stdin, | 54 | - stdin=stdin, |
55 | - stdout=subprocess.PIPE, | 55 | - stdout=subprocess.PIPE, |
56 | - stderr=stderr_dir, | 56 | - stderr=stderr_dir, |
@@ -78,7 +78,7 @@ index 0f2a995..05a253c 100644 | |||
78 | - program_log.debug("Return code: %d", proc.returncode) | 78 | - program_log.debug("Return code: %d", proc.returncode) |
79 | - | 79 | - |
80 | - return (proc.returncode, out) | 80 | - return (proc.returncode, out) |
81 | 81 | + | |
82 | + res, out = timeout_command(argv, 10, | 82 | + res, out = timeout_command(argv, 10, |
83 | + stdin=stdin, | 83 | + stdin=stdin, |
84 | + stdout=subprocess.PIPE, | 84 | + stdout=subprocess.PIPE, |
@@ -94,9 +94,10 @@ index 0f2a995..05a253c 100644 | |||
94 | + program_log.info("%s", line) | 94 | + program_log.info("%s", line) |
95 | + | 95 | + |
96 | + return (res, out) | 96 | + return (res, out) |
97 | + | ||
98 | |||
97 | 99 | ||
98 | def run_program(*args, **kwargs): | 100 | def run_program(*args, **kwargs): |
99 | return _run_program(*args, **kwargs)[0] | ||
100 | -- | 101 | -- |
101 | 2.7.4 | 102 | 2.7.4 |
102 | 103 | ||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch index 38f061ed0..861b2cdd4 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 325898f3f2951bbde07da47888175c427b11ddc3 Mon Sep 17 00:00:00 2001 | 1 | From 5d5436dfa3bdde7b4e87ce5a40cbc724199847d6 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Mon, 8 May 2017 16:18:02 +0800 | 3 | Date: Mon, 8 May 2017 16:18:02 +0800 |
4 | Subject: [PATCH 03/11] support infinit timeout | 4 | Subject: [PATCH 03/11] support infinit timeout |
@@ -11,10 +11,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
11 | 1 file changed, 8 insertions(+), 4 deletions(-) | 11 | 1 file changed, 8 insertions(+), 4 deletions(-) |
12 | 12 | ||
13 | diff --git a/blivet/util.py b/blivet/util.py | 13 | diff --git a/blivet/util.py b/blivet/util.py |
14 | index 05a253c..d6804be 100644 | 14 | index 4f05076..7e89949 100644 |
15 | --- a/blivet/util.py | 15 | --- a/blivet/util.py |
16 | +++ b/blivet/util.py | 16 | +++ b/blivet/util.py |
17 | @@ -157,6 +157,7 @@ class Path(str): | 17 | @@ -158,6 +158,7 @@ class Path(str): |
18 | def __hash__(self): | 18 | def __hash__(self): |
19 | return self._path.__hash__() | 19 | return self._path.__hash__() |
20 | 20 | ||
@@ -22,7 +22,7 @@ index 05a253c..d6804be 100644 | |||
22 | def timeout_command(argv, timeout, *args, **kwargs): | 22 | def timeout_command(argv, timeout, *args, **kwargs): |
23 | """call shell-command and either return its output or kill it | 23 | """call shell-command and either return its output or kill it |
24 | if it doesn't normally exit within timeout seconds and return None""" | 24 | if it doesn't normally exit within timeout seconds and return None""" |
25 | @@ -168,7 +169,7 @@ def timeout_command(argv, timeout, *args, **kwargs): | 25 | @@ -169,7 +170,7 @@ def timeout_command(argv, timeout, *args, **kwargs): |
26 | while proc.poll() is None: | 26 | while proc.poll() is None: |
27 | time.sleep(0.1) | 27 | time.sleep(0.1) |
28 | now = datetime.datetime.now() | 28 | now = datetime.datetime.now() |
@@ -31,7 +31,7 @@ index 05a253c..d6804be 100644 | |||
31 | os.kill(proc.pid, signal.SIGKILL) | 31 | os.kill(proc.pid, signal.SIGKILL) |
32 | os.waitpid(-1, os.WNOHANG) | 32 | os.waitpid(-1, os.WNOHANG) |
33 | program_log.debug("%d seconds timeout" % timeout) | 33 | program_log.debug("%d seconds timeout" % timeout) |
34 | @@ -182,7 +183,7 @@ def timeout_command(argv, timeout, *args, **kwargs): | 34 | @@ -183,7 +184,7 @@ def timeout_command(argv, timeout, *args, **kwargs): |
35 | program_log.debug("Return code: %d", proc.returncode) | 35 | program_log.debug("Return code: %d", proc.returncode) |
36 | return (proc.returncode, proc.stdout.read()) | 36 | return (proc.returncode, proc.stdout.read()) |
37 | 37 | ||
@@ -40,7 +40,7 @@ index 05a253c..d6804be 100644 | |||
40 | if env_prune is None: | 40 | if env_prune is None: |
41 | env_prune = [] | 41 | env_prune = [] |
42 | 42 | ||
43 | @@ -191,7 +192,10 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa | 43 | @@ -192,7 +193,10 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa |
44 | os.chroot(root) | 44 | os.chroot(root) |
45 | 45 | ||
46 | with program_log_lock: # pylint: disable=not-context-manager | 46 | with program_log_lock: # pylint: disable=not-context-manager |
@@ -52,7 +52,7 @@ index 05a253c..d6804be 100644 | |||
52 | 52 | ||
53 | env = os.environ.copy() | 53 | env = os.environ.copy() |
54 | env.update({"LC_ALL": "C", | 54 | env.update({"LC_ALL": "C", |
55 | @@ -204,7 +208,7 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa | 55 | @@ -205,7 +209,7 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa |
56 | else: | 56 | else: |
57 | stderr_dir = subprocess.PIPE | 57 | stderr_dir = subprocess.PIPE |
58 | 58 | ||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch index be997ac4f..526a3b1fb 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From c31df1c0f5323ddc70e0d1c6d11db2fbf7a024ad Mon Sep 17 00:00:00 2001 | 1 | From 3bb8d08bdec2f79bb13c0a44b81718d26e5bdabc Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Mon, 8 May 2017 16:30:20 +0800 | 3 | Date: Mon, 8 May 2017 16:30:20 +0800 |
4 | Subject: [PATCH 04/11] fix new.roots object is not iterable | 4 | Subject: [PATCH 04/11] fix new.roots object is not iterable |
@@ -11,10 +11,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | 11 | 1 file changed, 1 insertion(+), 1 deletion(-) |
12 | 12 | ||
13 | diff --git a/blivet/blivet.py b/blivet/blivet.py | 13 | diff --git a/blivet/blivet.py b/blivet/blivet.py |
14 | index 3405810..f42b73b 100644 | 14 | index ea08837..91c92b2 100644 |
15 | --- a/blivet/blivet.py | 15 | --- a/blivet/blivet.py |
16 | +++ b/blivet/blivet.py | 16 | +++ b/blivet/blivet.py |
17 | @@ -1198,7 +1198,7 @@ class Blivet(object): | 17 | @@ -1206,7 +1206,7 @@ class Blivet(object): |
18 | p = partition.disk.format.parted_disk.getPartitionByPath(partition.path) | 18 | p = partition.disk.format.parted_disk.getPartitionByPath(partition.path) |
19 | partition.parted_partition = p | 19 | partition.parted_partition = p |
20 | 20 | ||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch index ecb95039d..9c5d53b43 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b30a74671ca603e6bfd514f72d4fd7fd6fceef54 Mon Sep 17 00:00:00 2001 | 1 | From f783b9b00da5df176fcd7927b752f574ca6db319 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Fri, 26 Aug 2016 02:02:49 -0400 | 3 | Date: Fri, 26 Aug 2016 02:02:49 -0400 |
4 | Subject: [PATCH 05/11] fix incorrect timeout while system time changed | 4 | Subject: [PATCH 05/11] fix incorrect timeout while system time changed |
@@ -22,10 +22,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
22 | 1 file changed, 3 insertions(+), 3 deletions(-) | 22 | 1 file changed, 3 insertions(+), 3 deletions(-) |
23 | 23 | ||
24 | diff --git a/blivet/util.py b/blivet/util.py | 24 | diff --git a/blivet/util.py b/blivet/util.py |
25 | index d6804be..bc08af5 100644 | 25 | index 7e89949..5571e73 100644 |
26 | --- a/blivet/util.py | 26 | --- a/blivet/util.py |
27 | +++ b/blivet/util.py | 27 | +++ b/blivet/util.py |
28 | @@ -162,14 +162,14 @@ def timeout_command(argv, timeout, *args, **kwargs): | 28 | @@ -163,14 +163,14 @@ def timeout_command(argv, timeout, *args, **kwargs): |
29 | """call shell-command and either return its output or kill it | 29 | """call shell-command and either return its output or kill it |
30 | if it doesn't normally exit within timeout seconds and return None""" | 30 | if it doesn't normally exit within timeout seconds and return None""" |
31 | import subprocess, datetime, os, time, signal | 31 | import subprocess, datetime, os, time, signal |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch index da568a4b0..2e53a6477 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 0659d8a85bcdd76c0b23b8b5af6958783d35ac65 Mon Sep 17 00:00:00 2001 | 1 | From 8932ae933f2b6acf5e98c9956beff69ae430eed2 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Mon, 8 May 2017 16:33:15 +0800 | 3 | Date: Mon, 8 May 2017 16:33:15 +0800 |
4 | Subject: [PATCH 06/11] tweak btrfs packages | 4 | Subject: [PATCH 06/11] tweak btrfs packages |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch index e30121948..b2606d769 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 9c7a15312259854f12137a30229e52c30fb7c770 Mon Sep 17 00:00:00 2001 | 1 | From f53481dc4a56b8a996628733553e080bb0aafdd7 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Wed, 31 Aug 2016 21:30:32 -0400 | 3 | Date: Fri, 23 Nov 2018 17:07:22 +0800 |
4 | Subject: [PATCH 07/11] invoking mount with infinite timeout | 4 | Subject: [PATCH 07/11] invoking mount with infinite timeout |
5 | 5 | ||
6 | This large timeout is needed when running on machines with | 6 | This large timeout is needed when running on machines with |
@@ -14,18 +14,18 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/blivet/util.py b/blivet/util.py | 16 | diff --git a/blivet/util.py b/blivet/util.py |
17 | index bc08af5..b672787 100644 | 17 | index 5571e73..02c8033 100644 |
18 | --- a/blivet/util.py | 18 | --- a/blivet/util.py |
19 | +++ b/blivet/util.py | 19 | +++ b/blivet/util.py |
20 | @@ -256,7 +256,7 @@ def mount(device, mountpoint, fstype, options=None): | 20 | @@ -258,7 +258,7 @@ def mount(device, mountpoint, fstype, options=None): |
21 | makedirs(mountpoint) | ||
21 | 22 | ||
22 | argv = ["mount", "-t", fstype, "-o", options, device, mountpoint] | 23 | argv = ["mount", "-t", fstype, "-o", options, device, mountpoint] |
23 | try: | 24 | - return run_program(argv) |
24 | - rc = run_program(argv) | 25 | + return run_program(argv, timeout=-1) |
25 | + rc = run_program(argv, timeout=-1) | ||
26 | except OSError: | ||
27 | raise | ||
28 | 26 | ||
27 | |||
28 | def umount(mountpoint): | ||
29 | -- | 29 | -- |
30 | 2.7.4 | 30 | 2.7.4 |
31 | 31 | ||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch index feb5647ce..ade1862d7 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 7f57b2cd145d67c20beb02d5495b502f7af012cd Mon Sep 17 00:00:00 2001 | 1 | From 12e2579333258d1a690f8718e91b0f217078e886 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Mon, 8 May 2017 03:54:12 -0400 | 3 | Date: Mon, 8 May 2017 03:54:12 -0400 |
4 | Subject: [PATCH 08/11] use oe variable to replace hardcoded dir | 4 | Subject: [PATCH 08/11] use oe variable to replace hardcoded dir |
@@ -11,7 +11,7 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
11 | 1 file changed, 4 insertions(+), 4 deletions(-) | 11 | 1 file changed, 4 insertions(+), 4 deletions(-) |
12 | 12 | ||
13 | diff --git a/setup.py b/setup.py | 13 | diff --git a/setup.py b/setup.py |
14 | index 7edab2c..9be3187 100644 | 14 | index b745a79..b5b4258 100644 |
15 | --- a/setup.py | 15 | --- a/setup.py |
16 | +++ b/setup.py | 16 | +++ b/setup.py |
17 | @@ -61,10 +61,10 @@ class blivet_sdist(sdist): | 17 | @@ -61,10 +61,10 @@ class blivet_sdist(sdist): |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0009-invoking-fsck-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0009-invoking-fsck-with-infinite-timeout.patch index 30d2d3ec9..f4778779b 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0009-invoking-fsck-with-infinite-timeout.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0009-invoking-fsck-with-infinite-timeout.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From c757666f42f543baeed5df61269798c085665d9b Mon Sep 17 00:00:00 2001 | 1 | From 9624b6d0dda40aaecbaf9530be819943575a2ec6 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Thu, 1 Jun 2017 16:05:27 +0800 | 3 | Date: Thu, 1 Jun 2017 16:05:27 +0800 |
4 | Subject: [PATCH 09/11] invoking fsck with infinite timeout | 4 | Subject: [PATCH 09/11] invoking fsck with infinite timeout |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch index b2f450149..f12849045 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 42d8e57c748951098534bf7f52c4ebc790ef66e9 Mon Sep 17 00:00:00 2001 | 1 | From 33844f6773a676bd57240954e402ae9a843663a4 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Fri, 16 Jun 2017 15:43:00 +0800 | 3 | Date: Fri, 16 Jun 2017 15:43:00 +0800 |
4 | Subject: [PATCH 10/11] invoking mkfs with infinite timeout | 4 | Subject: [PATCH 10/11] invoking mkfs with infinite timeout |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch index f24ce0a80..13c2933f0 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch +++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From a4753b3cbbd5aee59dc53eb16564cafd9862763e Mon Sep 17 00:00:00 2001 | 1 | From 21ca2b859a49e96a230d55a7866dfc7ed5d1366c Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Hongxu Jia <hongxu.jia@windriver.com> |
3 | Date: Tue, 6 Mar 2018 17:28:56 +0800 | 3 | Date: Tue, 6 Mar 2018 17:28:56 +0800 |
4 | Subject: [PATCH 11/11] invoking dd with infinite timeout | 4 | Subject: [PATCH 11/11] invoking dd with infinite timeout |
@@ -14,10 +14,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | |||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py | 16 | diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py |
17 | index 47ff547..0cd1614 100644 | 17 | index 623e1c9..141d8ad 100644 |
18 | --- a/blivet/devices/partition.py | 18 | --- a/blivet/devices/partition.py |
19 | +++ b/blivet/devices/partition.py | 19 | +++ b/blivet/devices/partition.py |
20 | @@ -621,7 +621,7 @@ class PartitionDevice(StorageDevice): | 20 | @@ -618,7 +618,7 @@ class PartitionDevice(StorageDevice): |
21 | cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs, | 21 | cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs, |
22 | "seek=%d" % start, "count=%d" % count] | 22 | "seek=%d" % start, "count=%d" % count] |
23 | try: | 23 | try: |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch deleted file mode 100644 index 886e3ff93..000000000 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0012-remove-dmraid-dependency-check.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 4476e846a1e64dde17df2e2370c803ce695514f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Mon, 6 Aug 2018 17:18:27 +0800 | ||
4 | Subject: [PATCH] remove dmraid dependency check | ||
5 | |||
6 | OE does not support dmraid, remove it from dependency check | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
11 | --- | ||
12 | blivet/tasks/availability.py | 3 +-- | ||
13 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/blivet/tasks/availability.py b/blivet/tasks/availability.py | ||
16 | index 9a87cfd..843cf6a 100644 | ||
17 | --- a/blivet/tasks/availability.py | ||
18 | +++ b/blivet/tasks/availability.py | ||
19 | @@ -316,8 +316,7 @@ BLOCKDEV_DM_ALL_MODES = (blockdev.DMTechMode.CREATE_ACTIVATE | | ||
20 | blockdev.DMTechMode.QUERY) | ||
21 | BLOCKDEV_DM = BlockDevTechInfo(plugin_name="dm", | ||
22 | check_fn=blockdev.dm_is_tech_avail, | ||
23 | - technologies={blockdev.DMTech.MAP: BLOCKDEV_DM_ALL_MODES, | ||
24 | - blockdev.DMTech.RAID: BLOCKDEV_DM_ALL_MODES}) | ||
25 | + technologies={blockdev.DMTech.MAP: BLOCKDEV_DM_ALL_MODES}) | ||
26 | BLOCKDEV_DM_TECH = BlockDevMethod(BLOCKDEV_DM) | ||
27 | |||
28 | # libblockdev loop plugin required technologies and modes | ||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch deleted file mode 100644 index 33b5f51f9..000000000 --- a/meta-python/recipes-extended/python-blivet/python3-blivet/0013-add-Z-y-and-y-to-lvm.pvcreate.patch +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | From bddbfa499df16b108f2d892ee48d65617523c33d Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Thu, 9 Aug 2018 11:00:39 +0800 | ||
4 | Subject: [PATCH] add `-Z y' and `-y' to lvm.pvcreate | ||
5 | |||
6 | While reinstall a crypt fs, it occasionally failed | ||
7 | [snip] | ||
8 | |gi.overrides.BlockDev.LVMError: Process reported exit code 5: | ||
9 | WARNING: atari signature detected on /dev/mapper/luks-0e5f891c | ||
10 | -7701-48bc-a41e-8d626b6ef953 at offset 466. Wipe it? [y/n]: | ||
11 | [snip] | ||
12 | |||
13 | Add `-Z y' and `-y' to lvm.pvcreate | ||
14 | |||
15 | Upstream-Status: Submitted [https://github.com/storaged-project/blivet/pull/714] | ||
16 | |||
17 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
18 | --- | ||
19 | blivet/formats/lvmpv.py | 6 +++--- | ||
20 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/blivet/formats/lvmpv.py b/blivet/formats/lvmpv.py | ||
23 | index 260cc0b..4bbb46f 100644 | ||
24 | --- a/blivet/formats/lvmpv.py | ||
25 | +++ b/blivet/formats/lvmpv.py | ||
26 | @@ -120,9 +120,9 @@ class LVMPhysicalVolume(DeviceFormat): | ||
27 | log_method_call(self, device=self.device, | ||
28 | type=self.type, status=self.status) | ||
29 | |||
30 | - # Consider use of -Z|--zero | ||
31 | - # -f|--force or -y|--yes may be required | ||
32 | - blockdev.lvm.pvcreate(self.device, data_alignment=self.data_alignment) | ||
33 | + ea_zero = blockdev.ExtraArg.new("-Z", "y") | ||
34 | + ea_yes = blockdev.ExtraArg.new("-y", "") | ||
35 | + blockdev.lvm.pvcreate(self.device, data_alignment=self.data_alignment, extra=[ea_zero, ea_yes]) | ||
36 | |||
37 | def _destroy(self, **kwargs): | ||
38 | log_method_call(self, device=self.device, | ||
39 | -- | ||
40 | 2.7.4 | ||
41 | |||
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.1.bb index 75f02f13d..df8cc07d5 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.0.1.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.1.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
8 | S = "${WORKDIR}/git" | 8 | S = "${WORKDIR}/git" |
9 | B = "${S}" | 9 | B = "${S}" |
10 | 10 | ||
11 | SRCREV = "ddc24c71bad10208b11ea0c45853898fadd7030b" | 11 | SRCREV = "0a1f8374197f5a5fb368de90a7f1c1258b7cd2b9" |
12 | SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ | 12 | SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ |
13 | file://0001-comment-out-selinux.patch \ | 13 | file://0001-comment-out-selinux.patch \ |
14 | file://0002-run_program-support-timeout.patch \ | 14 | file://0002-run_program-support-timeout.patch \ |
@@ -21,8 +21,6 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ | |||
21 | file://0009-invoking-fsck-with-infinite-timeout.patch \ | 21 | file://0009-invoking-fsck-with-infinite-timeout.patch \ |
22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ | 22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
23 | file://0011-invoking-dd-with-infinite-timeout.patch \ | 23 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
24 | file://0012-remove-dmraid-dependency-check.patch \ | ||
25 | file://0013-add-Z-y-and-y-to-lvm.pvcreate.patch \ | ||
26 | " | 24 | " |
27 | 25 | ||
28 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" | 26 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" |