summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.5.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.5.bb
new file mode 100644
index 000000000..ac507ca0e
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.5.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "52ae8c000843c05abd1d8749f44bbe2e5d891d3d"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
13"
14
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "systemd"
17
18inherit setuptools3 python3native
19
20RDEPENDS_${PN} = "python3-pygobject python3 \
21 python3-blivet gtk+3 \
22 python3-pid libreport \
23"
24
25FILES_${PN} += " \
26 ${datadir}/* \
27 "