summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.3.0.bb')
-rw-r--r--meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.3.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.3.0.bb b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.3.0.bb
new file mode 100644
index 000000000..127aa8b4a
--- /dev/null
+++ b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_1.3.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A set of tools using pywbem"
2DESCRIPTION = "A set of tools using pywbem to communicate with WBEM servers"
3HOMEPAGE = "https://pywbemtools.readthedocs.io/en/stable/"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
6
7SRC_URI[sha256sum] = "9d0162b74c0b34d4500c099dddfe518cadc295a1a7bfb0abefa740a134d80fea"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN}:class-target += "\
12 python3-ply \
13 python3-pyyaml \
14 python3-six \
15 python3-pywbem \
16 python3-click \
17 python3-requests \
18 python3-prompt-toolkit \
19 python3-mock \
20 python3-packaging \
21 python3-nocasedict \
22 python3-yamlloader \
23 python3-click-repl \
24 python3-click-spinner \
25 python3-asciitree \
26 python3-tabulate \
27 python3-pydicti \
28 python3-nocaselist \
29 python3-custom-inherit \
30"
31
32BBCLASSEXTEND = "native"