summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb')
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb
new file mode 100644
index 000000000..8c03398ed
--- /dev/null
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Cross-platform locking library"
2DESCRIPTION = "Portalocker is a library to provide an easy API to file locking"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=152634da660a374ca18c0734ed07c63c"
6
7SRC_URI[sha256sum] = "ef1bf844e878ab08aee7e40184156e1151f228f103aa5c6bd0724cc330960f8f"
8
9DEPENDS += "python3-setuptools-scm-native"
10
11inherit pypi python_setuptools_build_meta ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-multiprocessing \
19 python3-pytest \
20 python3-redis \
21 python3-unittest-automake-output \
22 redis \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/portalocker_tests/* ${D}${PTEST_PATH}/tests/
28 rm -rf ${D}${PTEST_PATH}/tests/test_combined.py
29}
30
31RDEPENDS:${PN} += " \
32 python3-fcntl \
33 python3-logging \
34"
35
36BBCLASSEXTEND = "native nativesdk"