summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
new file mode 100644
index 000000000..bfb4f6f87
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://fedorahosted.org/pyparted/"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "\
8 file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9 file://src/_pedmodule.c;startline=10;endline=22;md5=70c62bd73782a03f56a0571a9f08ea46 \
10"
11DEPENDS += "parted"
12
13SRC_URI = "https://fedorahosted.org/releases/p/y/pyparted/pyparted-${PV}.tar.gz"
14SRC_URI[md5sum] = "f16c7ef7f5fa4a43fcb2a4654b487e39"
15SRC_URI[sha256sum] = "a56712e3d058ce3d859c158236dbbf45224018919efd3d880ea80f9e0d0bebbb"
16S = "${WORKDIR}/pyparted-${PV}"
17
18inherit distutils
19
20RDEPENDS_${PN} += "python-stringold python-codecs python-math"
21RDEPENDS_${PN}_class-native = ""
22
23BBCLASSEXTEND += "native"