summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
new file mode 100644
index 000000000..d3373f4ae
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "A python module for system storage configuration"
2HOMEPAGE = "http://fedoraproject.org/wiki/blivet"
3LICENSE = "LGPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "f7d9027e4fdad11187980e73726cd75a2dc962c2"
12SRC_URI = "git://github.com/storaged-project/blivet.git;branch=3.4-release \
13 file://0002-run_program-support-timeout.patch \
14 file://0003-support-infinit-timeout.patch \
15 file://0004-fix-new.roots-object-is-not-iterable.patch \
16 file://0005-fix-incorrect-timeout-while-system-time-changed.patch \
17 file://0006-tweak-btrfs-packages.patch \
18 file://0007-invoking-mount-with-infinite-timeout.patch \
19 file://0008-use-oe-variable-to-replace-hardcoded-dir.patch \
20 file://0009-invoking-fsck-with-infinite-timeout.patch \
21 file://0010-invoking-mkfs-with-infinite-timeout.patch \
22 file://0011-invoking-dd-with-infinite-timeout.patch \
23"
24
25UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$"
26
27inherit features_check
28REQUIRED_DISTRO_FEATURES = "systemd"
29
30inherit setuptools3 python3native
31
32RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
33 parted python3-pyparted multipath-tools \
34 lsof cryptsetup libblockdev \
35 libbytesize \
36"
37
38FILES:${PN} += " \
39 ${datadir}/dbus-1/system-services \
40"
41
42inherit systemd
43
44SYSTEMD_AUTO_ENABLE = "disable"
45SYSTEMD_SERVICE:${PN} = "blivet.service"