diff options
Diffstat (limited to 'meta-python/recipes-devtools')
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cachetools.inc b/meta-python/recipes-devtools/python/python-cachetools.inc new file mode 100644 index 000000000..52ae3186d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cachetools.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Extensible memoizing collections and decorators" | ||
2 | HOMEPAGE = "https://github.com/tkem/cachetools" | ||
3 | DESCRIPTION = "This module provides various memoizing \ | ||
4 | collections and decorators, including variants of the \ | ||
5 | Python 3 Standard Library @lru_cache function decorator." | ||
6 | SECTION = "devel/python" | ||
7 | |||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=27f7518eb6f7dc686d0f953b2f28dae5" | ||
10 | |||
11 | inherit pypi | ||
12 | |||
13 | SRC_URI[md5sum] = "a7b1c5eb5390d50067c62d7bcb4e875c" | ||
14 | SRC_URI[sha256sum] = "9efcc9fab3b49ab833475702b55edd5ae07af1af7a4c627678980b45e459c460" | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb b/meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb new file mode 100644 index 000000000..8c12ad042 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-cachetools_3.1.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-cachetools.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb b/meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb new file mode 100644 index 000000000..76b2f6785 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cachetools_3.1.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-cachetools.inc | ||