diff options
Diffstat (limited to 'meta-python/recipes-devtools')
3 files changed, 27 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyserial.inc b/meta-python/recipes-devtools/python/python-pyserial.inc new file mode 100644 index 000000000..0fd674756 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyserial.inc | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "Serial Port Support for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c557c64905dac5b725980b9505bf8d7b" | ||
5 | SRCNAME = "pyserial" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
8 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
9 | |||
10 | # FIXME might stop packaging serialwin32 and serialjava files | ||
11 | |||
12 | RDEPENDS_${PN} = "\ | ||
13 | ${PYTHON_PN}-fcntl \ | ||
14 | ${PYTHON_PN}-io \ | ||
15 | ${PYTHON_PN}-stringold \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "794506184df83ef2290de0d18803dd11" | ||
19 | SRC_URI[sha256sum] = "3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477" | ||
diff --git a/meta-python/recipes-devtools/python/python-pyserial_2.7.bb b/meta-python/recipes-devtools/python/python-pyserial_2.7.bb index 276db34bf..ad2b350b0 100644 --- a/meta-python/recipes-devtools/python/python-pyserial_2.7.bb +++ b/meta-python/recipes-devtools/python/python-pyserial_2.7.bb | |||
@@ -1,21 +1,2 @@ | |||
1 | SUMMARY = "Serial Port Support for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c557c64905dac5b725980b9505bf8d7b" | ||
5 | SRCNAME = "pyserial" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
8 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
9 | |||
10 | inherit setuptools | 1 | inherit setuptools |
11 | 2 | require python-pyserial.inc | |
12 | # FIXME might stop packaging serialwin32 and serialjava files | ||
13 | |||
14 | RDEPENDS_${PN} = "\ | ||
15 | python-fcntl \ | ||
16 | python-io \ | ||
17 | python-stringold \ | ||
18 | " | ||
19 | |||
20 | SRC_URI[md5sum] = "794506184df83ef2290de0d18803dd11" | ||
21 | SRC_URI[sha256sum] = "3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_2.7.bb b/meta-python/recipes-devtools/python/python3-pyserial_2.7.bb new file mode 100644 index 000000000..17ed3f8bc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyserial_2.7.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pyserial.inc | ||
3 | |||
4 | do_install_append() { | ||
5 | rm -f ${D}${bindir}/miniterm.py | ||
6 | rmdir ${D}${bindir} | ||
7 | } | ||