summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-restful.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-restful.inc b/meta-python/recipes-devtools/python/python-flask-restful.inc
new file mode 100644
index 000000000..0485f85aa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-restful.inc
@@ -0,0 +1,16 @@
1SUMMARY = "Simple framework for creating REST APIs"
2DESCRIPTION = "\
3Flask-RESTful is an extension for Flask that adds support for quickly building \
4REST APIs"
5HOMEPAGE = "https://github.com/flask-restful/flask-restful"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=685bb55ed99a366bb431995f5eef2783"
8
9SRC_URI[md5sum] = "8243ca101185b130d8fa529cbdbdbddd"
10SRC_URI[sha256sum] = "5795519501347e108c436b693ff9a4d7b373a3ac9069627d64e4001c05dd3407"
11
12inherit pypi
13
14PYPI_PACKAGE = "Flask-RESTful"
15
16RDEPENDS_${PN} = "${PYTHON_PN}-flask"
diff --git a/meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb b/meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb
new file mode 100644
index 000000000..1968d1d9d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-restful_0.3.6.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-flask-restful.inc
diff --git a/meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb
new file mode 100644
index 000000000..6bff59a56
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.6.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-flask-restful.inc