diff options
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch | 38 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb | 15 |
2 files changed, 0 insertions, 53 deletions
diff --git a/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch b/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch deleted file mode 100644 index c25b2457e..000000000 --- a/meta-python/recipes-devtools/python/python3-twofish/0001-Fix-missing-return-statements-in-module-stubs.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 5704610f4b3aed5210e9c5b7c05ff8b5b2364c9c Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Mon, 12 Aug 2019 08:18:21 +0000 | ||
4 | Subject: [PATCH] Fix missing return statements in module stubs | ||
5 | |||
6 | * fixes build with -Werror=return-type | ||
7 | twofish.c: In function 'init_twofish': | ||
8 | twofish.c:45:1: error: control reaches end of non-void function [-Werror=return-type] | ||
9 | 45 | PyMODINIT_FUNC init_twofish(void) { } | ||
10 | | ^~~~~~~~~~~~~~ | ||
11 | twofish.c: In function 'PyInit__twofish': | ||
12 | twofish.c:46:1: error: control reaches end of non-void function [-Werror=return-type] | ||
13 | 46 | PyMODINIT_FUNC PyInit__twofish(void) { } | ||
14 | | ^~~~~~~~~~~~~~ | ||
15 | cc1: some warnings being treated as errors | ||
16 | |||
17 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
18 | |||
19 | Upstream-Status: Submitted [https://github.com/keybase/python-twofish/pull/6] | ||
20 | --- | ||
21 | twofish.c | 4 ++-- | ||
22 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
23 | |||
24 | diff --git a/twofish.c b/twofish.c | ||
25 | index e324c34..d4487d8 100644 | ||
26 | --- a/twofish.c | ||
27 | +++ b/twofish.c | ||
28 | @@ -42,5 +42,5 @@ DL_EXPORT(void) exp_Twofish_decrypt(Twofish_key * xkey, uint8_t c[16], uint8_t p | ||
29 | We need a stub init_twofish function so the module will link as a proper module. | ||
30 | Do not import _twofish from python; it will not work since _twofish is not a *real* module | ||
31 | */ | ||
32 | -PyMODINIT_FUNC init_twofish(void) { } | ||
33 | -PyMODINIT_FUNC PyInit__twofish(void) { } | ||
34 | +PyMODINIT_FUNC init_twofish(void) { return NULL; } | ||
35 | +PyMODINIT_FUNC PyInit__twofish(void) { return NULL; } | ||
36 | -- | ||
37 | 2.17.1 | ||
38 | |||
diff --git a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb b/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb deleted file mode 100644 index 94fb71090..000000000 --- a/meta-python/recipes-devtools/python/python3-twofish_0.3.0.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | SUMMARY = "Bindings for the Twofish implementation by Niels Ferguson" | ||
2 | DESCRIPTION = "Bindings for the Twofish implementation by Niels Ferguson\ | ||
3 | libtwofish-dev." | ||
4 | HOMEPAGE = "http://github.com/keybase/python-twofish" | ||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=33a63abf6d7567b1689d8ce69f00e43b" | ||
7 | |||
8 | SRC_URI += "file://0001-Fix-missing-return-statements-in-module-stubs.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "d7d22f16dc4ffa0e3ae2200654033abe" | ||
11 | SRC_URI[sha256sum] = "b09d8bb50d33b23ff34cafb1f9209f858f752935c6a5c901efb92a41acb830fa" | ||
12 | |||
13 | inherit pypi setuptools3 | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||