summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-greenlet.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-greenlet_0.4.12.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-greenlet_0.4.12.bb2
3 files changed, 13 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-greenlet.inc b/meta-python/recipes-devtools/python/python-greenlet.inc
new file mode 100644
index 000000000..35820db2f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-greenlet.inc
@@ -0,0 +1,9 @@
1SUMMARY = "Python lightweight in-process concurrent programming"
2LICENSE = "MIT & PSF"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
4 file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
5
6SRC_URI[md5sum] = "e8637647d58a26c4a1f51ca393e53c00"
7SRC_URI[sha256sum] = "e4c99c6010a5d153d481fdaf63b8a0782825c0721506d880403a3b9b82ae347e"
8
9inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-greenlet_0.4.12.bb b/meta-python/recipes-devtools/python/python-greenlet_0.4.12.bb
index 4fc2c1d27..c14976ed3 100644
--- a/meta-python/recipes-devtools/python/python-greenlet_0.4.12.bb
+++ b/meta-python/recipes-devtools/python/python-greenlet_0.4.12.bb
@@ -1,10 +1,2 @@
1SUMMARY = "Python lightweight in-process concurrent programming" 1inherit distutils
2LICENSE = "MIT & PSF" 2require python-greenlet.inc
3LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
4 file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
5
6SRC_URI[md5sum] = "e8637647d58a26c4a1f51ca393e53c00"
7SRC_URI[sha256sum] = "e4c99c6010a5d153d481fdaf63b8a0782825c0721506d880403a3b9b82ae347e"
8
9inherit pypi distutils
10
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_0.4.12.bb b/meta-python/recipes-devtools/python/python3-greenlet_0.4.12.bb
new file mode 100644
index 000000000..1aedf7fa8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-greenlet_0.4.12.bb
@@ -0,0 +1,2 @@
1inherit distutils3
2require python-greenlet.inc