summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/gyp/gyp-py2_git.bb2
-rw-r--r--meta-python/recipes-devtools/gyp/gyp.inc13
-rw-r--r--meta-python/recipes-devtools/gyp/gyp_git.bb15
3 files changed, 16 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/gyp/gyp-py2_git.bb b/meta-python/recipes-devtools/gyp/gyp-py2_git.bb
new file mode 100644
index 000000000..d69b92ce6
--- /dev/null
+++ b/meta-python/recipes-devtools/gyp/gyp-py2_git.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require gyp.inc
diff --git a/meta-python/recipes-devtools/gyp/gyp.inc b/meta-python/recipes-devtools/gyp/gyp.inc
new file mode 100644
index 000000000..98ed42cc9
--- /dev/null
+++ b/meta-python/recipes-devtools/gyp/gyp.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
2HOMEPAGE = "https://gyp.gsrc.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
5SECTION = "devel"
6
7SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
8SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
9
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb
index 61f3c8637..8e48a27fa 100644
--- a/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -1,15 +1,2 @@
1DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
2HOMEPAGE = "https://gyp.gsrc.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
5SECTION = "devel"
6
7SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
8SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
9
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13inherit setuptools3 1inherit setuptools3
14 2require gyp.inc
15BBCLASSEXTEND = "native nativesdk"