diff options
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/gyp/gyp-py2_git.bb | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/gyp/gyp.inc | 13 | ||||
-rw-r--r-- | meta-python/recipes-devtools/gyp/gyp_git.bb | 15 |
3 files changed, 16 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/gyp/gyp-py2_git.bb b/meta-python/recipes-devtools/gyp/gyp-py2_git.bb new file mode 100644 index 000000000..d69b92ce6 --- /dev/null +++ b/meta-python/recipes-devtools/gyp/gyp-py2_git.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require gyp.inc | ||
diff --git a/meta-python/recipes-devtools/gyp/gyp.inc b/meta-python/recipes-devtools/gyp/gyp.inc new file mode 100644 index 000000000..98ed42cc9 --- /dev/null +++ b/meta-python/recipes-devtools/gyp/gyp.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems." | ||
2 | HOMEPAGE = "https://gyp.gsrc.io/" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd" | ||
5 | SECTION = "devel" | ||
6 | |||
7 | SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https" | ||
8 | SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | PV = "0.1+git${SRCPV}" | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb index 61f3c8637..8e48a27fa 100644 --- a/meta-python/recipes-devtools/gyp/gyp_git.bb +++ b/meta-python/recipes-devtools/gyp/gyp_git.bb | |||
@@ -1,15 +1,2 @@ | |||
1 | DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems." | ||
2 | HOMEPAGE = "https://gyp.gsrc.io/" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd" | ||
5 | SECTION = "devel" | ||
6 | |||
7 | SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https" | ||
8 | SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | PV = "0.1+git${SRCPV}" | ||
12 | |||
13 | inherit setuptools3 | 1 | inherit setuptools3 |
14 | 2 | require gyp.inc | |
15 | BBCLASSEXTEND = "native nativesdk" | ||