diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-cassandra-driver.inc | 33 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb | 35 |
2 files changed, 31 insertions, 37 deletions
diff --git a/meta-python/recipes-devtools/python/python-cassandra-driver.inc b/meta-python/recipes-devtools/python/python-cassandra-driver.inc deleted file mode 100644 index 53ebfec33..000000000 --- a/meta-python/recipes-devtools/python/python-cassandra-driver.inc +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | SUMMARY = "DataStax Python Driver for Apache Cassandra" | ||
2 | DESCRIPTION = "A modern, feature-rich and highly-tunable Python client \ | ||
3 | library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using \ | ||
4 | exclusively Cassandra's binary protocol and Cassandra Query Language v3." | ||
5 | HOMEPAGE = "https://github.com/datastax/python-driver" | ||
6 | SECTION = "devel/python" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | ||
9 | SRCNAME = "cassandra-driver" | ||
10 | |||
11 | SRC_URI[md5sum] = "c5bed026bf48c821424c1f6296193908" | ||
12 | SRC_URI[sha256sum] = "b65218e2582277f5b77d1436e420db8616f63e3437a9e839cdcd7172d760e861" | ||
13 | |||
14 | DISTUTILS_BUILD_ARGS += " \ | ||
15 | --no-libev \ | ||
16 | " | ||
17 | DISTUTILS_INSTALL_ARGS += " \ | ||
18 | --no-libev \ | ||
19 | " | ||
20 | |||
21 | inherit pypi | ||
22 | |||
23 | RDEPENDS_${PN} += "\ | ||
24 | ${PYTHON_PN}-cython \ | ||
25 | ${PYTHON_PN}-multiprocessing \ | ||
26 | ${PYTHON_PN}-six \ | ||
27 | ${PYTHON_PN}-json \ | ||
28 | libevent \ | ||
29 | " | ||
30 | |||
31 | DEPENDS += "\ | ||
32 | ${PYTHON_PN}-cython \ | ||
33 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb index 34f149d3f..768e557b9 100644 --- a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb +++ b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb | |||
@@ -1,8 +1,35 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "DataStax Python Driver for Apache Cassandra" |
2 | require python-cassandra-driver.inc | 2 | DESCRIPTION = "A modern, feature-rich and highly-tunable Python client \ |
3 | library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using \ | ||
4 | exclusively Cassandra's binary protocol and Cassandra Query Language v3." | ||
5 | HOMEPAGE = "https://github.com/datastax/python-driver" | ||
6 | SECTION = "devel/python" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | ||
9 | SRCNAME = "cassandra-driver" | ||
3 | 10 | ||
4 | # Requires concurrent which is currently in -misc | 11 | SRC_URI[md5sum] = "c5bed026bf48c821424c1f6296193908" |
5 | RDEPENDS_${PN} += " \ | 12 | SRC_URI[sha256sum] = "b65218e2582277f5b77d1436e420db8616f63e3437a9e839cdcd7172d760e861" |
13 | |||
14 | DISTUTILS_BUILD_ARGS += " \ | ||
15 | --no-libev \ | ||
16 | " | ||
17 | DISTUTILS_INSTALL_ARGS += " \ | ||
18 | --no-libev \ | ||
19 | " | ||
20 | |||
21 | inherit pypi setuptools3 | ||
22 | |||
23 | RDEPENDS_${PN} += "\ | ||
24 | ${PYTHON_PN}-cython \ | ||
25 | ${PYTHON_PN}-json \ | ||
6 | ${PYTHON_PN}-misc \ | 26 | ${PYTHON_PN}-misc \ |
27 | ${PYTHON_PN}-multiprocessing \ | ||
7 | ${PYTHON_PN}-numbers \ | 28 | ${PYTHON_PN}-numbers \ |
29 | ${PYTHON_PN}-six \ | ||
30 | libevent \ | ||
31 | " | ||
32 | |||
33 | DEPENDS += "\ | ||
34 | ${PYTHON_PN}-cython \ | ||
8 | " | 35 | " |