diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 24 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-behave.inc b/meta-python/recipes-devtools/python/python-behave.inc new file mode 100644 index 000000000..ded75801d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-behave.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "A behavior-driven development framework, Python style" | ||
2 | HOMEPAGE = "https://github.com/behave/behave" | ||
3 | LICENSE = "BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06" | ||
5 | |||
6 | SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d" | ||
7 | SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN} += " \ | ||
12 | ${PYTHON_PN}-parse-type \ | ||
13 | ${PYTHON_PN}-setuptools \ | ||
14 | ${PYTHON_PN}-six \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-behave_1.2.6.bb b/meta-python/recipes-devtools/python/python-behave_1.2.6.bb index 679730262..66221682a 100644 --- a/meta-python/recipes-devtools/python/python-behave_1.2.6.bb +++ b/meta-python/recipes-devtools/python/python-behave_1.2.6.bb | |||
@@ -1,10 +1,8 @@ | |||
1 | SUMMARY = "A behavior-driven development framework, Python style" | 1 | inherit setuptools |
2 | LICENSE = "BSD" | 2 | require python-behave.inc |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d950439e8ea6ed233e4288f5e1a49c06" | ||
4 | 3 | ||
5 | SRC_URI[md5sum] = "3f05c859a1c45f5ed33e925817ad887d" | 4 | RDEPENDS_${PN} += " \ |
6 | SRC_URI[sha256sum] = "b9662327aa53294c1351b0a9c369093ccec1d21026f050c3bd9b3e5cccf81a86" | 5 | ${PYTHON_PN}-argparse \ |
7 | 6 | ${PYTHON_PN}-enum34 \ | |
8 | RDEPENDS_${PN} += "python-difflib python-setuptools python-pkgutil python-misc python-argparse python-xml python-enum34 python-parse python-parse-type python-six" | 7 | ${PYTHON_PN}-traceback2 \ |
9 | 8 | " | |
10 | inherit pypi setuptools | ||
diff --git a/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb new file mode 100644 index 000000000..1c55871b1 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-behave_1.2.6.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-behave.inc | ||