summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-systemd.inc20
-rw-r--r--meta-python/recipes-devtools/python/python3-systemd_234.bb23
2 files changed, 20 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd.inc b/meta-python/recipes-devtools/python/python-systemd.inc
deleted file mode 100644
index b14f82501..000000000
--- a/meta-python/recipes-devtools/python/python-systemd.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Python interface for libsystemd"
2HOMEPAGE = "https://github.com/systemd/python-systemd"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
8RDEPENDS_${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging"
9REQUIRED_DISTRO_FEATURES = "systemd"
10inherit pypi features_check
11
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
14
15# allow for common patches for python- and python3-systemd
16FILESEXTRAPATHS_prepend := "${THISDIR}/python-systemd:"
17
18SRC_URI += "file://endian.patch"
19
20SRC_URI_append_libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_234.bb
index 78ec43156..6914cf920 100644
--- a/meta-python/recipes-devtools/python/python3-systemd_234.bb
+++ b/meta-python/recipes-devtools/python/python3-systemd_234.bb
@@ -1,3 +1,20 @@
1require python-systemd.inc 1SUMMARY = "Python interface for libsystemd"
2RDEPENDS_${PN} += "python3-syslog" 2HOMEPAGE = "https://github.com/systemd/python-systemd"
3inherit setuptools3 3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
8RDEPENDS_${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog"
9REQUIRED_DISTRO_FEATURES = "systemd"
10inherit pypi features_check setuptools3
11
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
14
15# allow for common patches for python- and python3-systemd
16FILESEXTRAPATHS_prepend := "${THISDIR}/python-systemd:"
17
18SRC_URI += "file://endian.patch"
19
20SRC_URI_append_libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"