summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb17
2 files changed, 17 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf.inc b/meta-python/recipes-devtools/python/python-flask-wtf.inc
new file mode 100644
index 000000000..3a959aed7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-wtf.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "Simple integration of Flask and WTForms."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3"
4
5SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e"
6SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e"
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/python-flask-wtf:"
9SRC_URI += " file://import-simplejson-as-json.patch"
10
11PYPI_PACKAGE = "Flask-WTF"
12
13RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-wtforms \
15 ${PYTHON_PN}-simplejson \
16"
diff --git a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
index 79afaf659..dbf091bc0 100644
--- a/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
+++ b/meta-python/recipes-devtools/python/python-flask-wtf_0.12.bb
@@ -1,17 +1,2 @@
1DESCRIPTION = "Simple integration of Flask and WTForms."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=507e8635f25a06dc4f041a3a1b3359b3"
4
5SRC_URI[md5sum] = "c53a74e8ba481bf53405fd5efdf0339e"
6SRC_URI[sha256sum] = "bd99316c97ed1d1cb90b8f0c242c86420a891a6a2058f20717e424bf5b0bb80e"
7
8SRC_URI += " file://import-simplejson-as-json.patch"
9
10PYPI_PACKAGE = "Flask-WTF"
11
12inherit pypi setuptools 1inherit pypi setuptools
13 2require python-flask-wtf.inc
14RDEPENDS_${PN} = "\
15 python-wtforms \
16 python-simplejson \
17"