summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb b/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
deleted file mode 100644
index 15d92065d..000000000
--- a/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
5
6SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba"
7SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b"
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13PYPI_PACKAGE = "yarl"
14
15inherit pypi ptest setuptools3
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-multidict \
19 ${PYTHON_PN}-idna \
20"
21
22RDEPENDS_${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}