summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb b/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb
new file mode 100644
index 000000000..a80f6c2db
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmlschema_3.3.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
2HOMEPAGE = "https://github.com/sissaschool/xmlschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=26aa26eda991a3a2b61c11b62d3fda65"
5
6SRC_URI[sha256sum] = "2066ecbc9728112073f6f44d17c5c16723aff1c7d22a7c4c6421e2d68ec5f0ea"
7
8PYPI_PACKAGE = "xmlschema"
9inherit pypi setuptools3
10
11DEPENDS += "\
12 python3-elementpath-native \
13"
14
15RDEPENDS:${PN} += "\
16 python3-elementpath \
17 python3-modules \
18"
19
20BBCLASSEXTEND = "native nativesdk"