summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-web3_5.29.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-web3_5.29.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_5.29.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-web3_5.29.2.bb b/meta-python/recipes-devtools/python/python3-web3_5.29.2.bb
new file mode 100644
index 000000000..c9820ebdf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_5.29.2.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A Python library for interacting with Ethereum."
2HOMEPAGE = "https://github.com/ethereum/web3.py"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dc2732bdc5e50382737979791cbb3b7"
6
7SRC_URI[sha256sum] = "f37b01f3dc32010b176cef01c2107bc25b7cf94b63c3269d4ec52d7e5ded9a36"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-aiohttp \
13 python3-distutils \
14 python3-eth-account \
15 python3-idna \
16 python3-lru-dict \
17 python3-requests \
18 python3-setuptools \
19 python3-websockets \
20"