summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb b/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
new file mode 100644
index 000000000..b3013180d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-unidiff_0.7.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Unified diff parsing/metadata extraction library"
2HOMEPAGE = "http://github.com/matiasb/python-unidiff"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
5
6SRC_URI[sha256sum] = "91bb13b4969514a400679d9ae5e29a6ffad85346087677f8b5e2e036af817447"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN} += " \
24 ${PYTHON_PN}-codecs \
25 ${PYTHON_PN}-io \
26"