summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb30
1 files changed, 28 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
index a646ac648..1aef28be0 100644
--- a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.1.bb
@@ -1,3 +1,29 @@
1inherit setuptools3 1DESCRIPTION = "Non-validating SQL parser module"
2require python-sqlparse.inc 2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
8 file://run-ptest \
9 "
10
11SRC_URI[md5sum] = "423047887a3590b04dd18f8caf843a2f"
12SRC_URI[sha256sum] = "e162203737712307dfe78860cc56c8da8a852ab2ee33750e33aeadf38d12c548"
13
14export BUILD_SYS
15export HOST_SYS
16
17inherit pypi ptest setuptools3
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-unixadmin \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
3BBCLASSEXTEND = "native nativesdk" 29BBCLASSEXTEND = "native nativesdk"