summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.20.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.20.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.20.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.20.bb
new file mode 100644
index 000000000..414b2f667
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.20.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b707d50badb798e1d897f2c8f649382d"
6
7SRC_URI[sha256sum] = "ca8a5ff2aa7f3ade6c498aaafce25b1eaeabe4e42b73e25519183e4566a16fc6"
8
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 python3-asyncio \
14 python3-compression \
15 python3-json \
16 python3-logging \
17 python3-netclient \
18 python3-numbers \
19 python3-pickle \
20 python3-profile \
21 python3-threading \
22 python3-typing-extensions \
23"
24
25BBCLASSEXTEND = "native nativesdk"