summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sentry-sdk_1.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sentry-sdk_1.24.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sentry-sdk_1.24.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.24.0.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.24.0.bb
new file mode 100644
index 000000000..9e4b87da9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.24.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "The new Python SDK for Sentry.io"
2DESCRIPTION = "This is the next line of the Python SDK \
3for Sentry, intended to replace the raven package on PyPI."
4HOMEPAGE = "https://github.com/getsentry/sentry-python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7fcb29c83dd48cb7b112d0dd81111a89"
7
8RDEPENDS:${PN} += "\
9 ${PYTHON_PN}-urllib3 \
10 ${PYTHON_PN}-core \
11 ${PYTHON_PN}-json \
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-threading \
14 ${PYTHON_PN}-compression \
15 ${PYTHON_PN}-datetime \
16"
17
18SRC_URI[sha256sum] = "0bbcecda9f51936904c1030e7fef0fe693e633888f02a14d1cb68646a50e83b3"
19
20PYPI_PACKAGE = "sentry-sdk"
21
22inherit pypi setuptools3