summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb b/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb
new file mode 100644
index 000000000..46ca600ea
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb
@@ -0,0 +1,16 @@
1SUMMARY = "A Python implementation of Recursive Length Prefix encoding (RLP)."
2HOMEPAGE = "https://github.com/ethereum/pyrlp"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7"
6
7SRC_URI[sha256sum] = "bcefb11013dfadf8902642337923bd0c786dc8a27cb4c21da6e154e52869ecb1"
8
9inherit pypi setuptools3
10
11DEPENDS += "python3-pip-native"
12
13RDEPENDS:${PN} += " \
14 python3-eth-utils \
15 python3-typing-extensions \
16"