summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
deleted file mode 100644
index 26332249d..000000000
--- a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From fc45beed40a86c8fc38fc430765c1c5d2c9961c2 Mon Sep 17 00:00:00 2001
2From: Fabio Berton <fabio.berton@ossystems.com.br>
3Date: Thu, 4 Mar 2021 09:26:48 -0300
4Subject: [PATCH] setup.py: Support idna version 3.1
5Organization: O.S. Systems Software LTDA.
6
7Change idna required version to use python3-idna recipe that currently
8is on version 3.1.
9
10Without this change python-request doesn't work as the idna version
11doesn't match the required versions. When bump python-request recipe,
12verify if the upstream project bumped the idna version and drop this
13patch.
14
15As this recipe was tested with python3-idna_3.1 don't allow higher
16versions.
17
18Upstream-Status: Inappropriate [embedded specific]
19
20Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
21---
22 setup.py | 2 +-
23 1 file changed, 1 insertion(+), 1 deletion(-)
24
25diff --git a/setup.py b/setup.py
26index 7ba4b2a2..9d3b973e 100755
27--- a/setup.py
28+++ b/setup.py
29@@ -43,7 +43,7 @@ packages = ['requests']
30
31 requires = [
32 'chardet>=3.0.2,<5',
33- 'idna>=2.5,<3',
34+ 'idna>=2.5,<3.2',
35 'urllib3>=1.21.1,<1.27',
36 'certifi>=2017.4.17'
37
38--
392.30.1
40